summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/files/tty-freeze.patch12
-rw-r--r--gui-wm/hyprland/hyprland-0.35.0-r3.ebuild (renamed from gui-wm/hyprland/hyprland-0.35.0-r2.ebuild)3
-rw-r--r--gui-wm/hyprland/hyprland-0.36.0-r2.ebuild (renamed from gui-wm/hyprland/hyprland-0.36.0-r1.ebuild)3
3 files changed, 18 insertions, 0 deletions
diff --git a/gui-wm/hyprland/files/tty-freeze.patch b/gui-wm/hyprland/files/tty-freeze.patch
new file mode 100644
index 000000000000..991593b8de86
--- /dev/null
+++ b/gui-wm/hyprland/files/tty-freeze.patch
@@ -0,0 +1,12 @@
+diff --git a/src/events/Misc.cpp b/src/events/Misc.cpp
+index b77cf038..eaaaec18 100644
+--- a/src/events/Misc.cpp
++++ b/src/events/Misc.cpp
+@@ -169,6 +169,7 @@ void Events::listener_sessionActive(wl_listener* listener, void* data) {
+
+ for (auto& m : g_pCompositor->m_vMonitors) {
+ g_pCompositor->scheduleFrameForMonitor(m.get());
++ g_pHyprRenderer->applyMonitorRule(m.get(), &m->activeMonitorRule, true);
+ }
+
+ g_pConfigManager->m_bWantsMonitorReload = true;
diff --git a/gui-wm/hyprland/hyprland-0.35.0-r2.ebuild b/gui-wm/hyprland/hyprland-0.35.0-r3.ebuild
index 81c8b1bbcb99..369ffc6eb951 100644
--- a/gui-wm/hyprland/hyprland-0.35.0-r2.ebuild
+++ b/gui-wm/hyprland/hyprland-0.35.0-r3.ebuild
@@ -95,6 +95,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/legacy-renderer-fix.patch"
+ # https://bugs.gentoo.org/926259
+ # https://github.com/hyprwm/Hyprland/issues/4839
+ "${FILESDIR}/tty-freeze.patch"
)
pkg_setup() {
diff --git a/gui-wm/hyprland/hyprland-0.36.0-r1.ebuild b/gui-wm/hyprland/hyprland-0.36.0-r2.ebuild
index 972fe7b33988..7190982afaef 100644
--- a/gui-wm/hyprland/hyprland-0.36.0-r1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.36.0-r2.ebuild
@@ -96,6 +96,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/legacy-renderer-fix.patch"
+ # https://bugs.gentoo.org/926259
+ # https://github.com/hyprwm/Hyprland/issues/4839
+ "${FILESDIR}/tty-freeze.patch"
)
pkg_setup() {