summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/Manifest2
-rw-r--r--gui-wm/hyprland/files/legacy-renderer-fix.patch33
-rw-r--r--gui-wm/hyprland/files/tty-freeze.patch12
-rw-r--r--gui-wm/hyprland/hyprland-0.35.0-r3.ebuild144
-rw-r--r--gui-wm/hyprland/hyprland-0.36.0-r2.ebuild145
5 files changed, 0 insertions, 336 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 1e7a8209db67..795cdad38016 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,5 +1,3 @@
DIST hyprland-0.34.0.gh.tar.gz 14128415 BLAKE2B 059fc8b849daeb71b08d7114fd8aea1264c0e9967f471df66b27aca46b95fd499d2929730ba66981bb7d6c423479533b280839db7839ca1df007825f72fb9bf8 SHA512 35cce0668a13d7e7fd220d62efd965a069ff0213996bfa47ca0852c6258881bc070020d4831364b325b71d8ce7373d1793a89006a4341088dcbaf01914920f1a
-DIST hyprland-0.35.0.gh.tar.gz 54200453 BLAKE2B f5a8a5ed5f5ca28e5fc5a329d5191abce458b9bf0b99bee970aaa4be40671bfe945dabe2b3ff34ca753beeb35ec7fe016e6a54669dbe1ee4f25e2c128c3e390d SHA512 5afe7c340b994f2542982d8c8fa837b2a43ef9e487810fec0b33e4a5cc9188b71e41a0be22839191cf15e9c1fdfd964d0751def51f93db438e4a45649077c8a7
-DIST hyprland-0.36.0.gh.tar.gz 54632144 BLAKE2B 8f27044702d50fd5b937cab096c340ed7b7c86fda65e2b15fd4704038f2f4a62eb5a75cf00cc721da66dd7aaf820052ba02d8457bef928ad0ecc8622d4e151c1 SHA512 964f60baf08d9e5cc978853f24d3fca8cb5115eab3dd5e9c6542db2bbb0b5b73fa61a863077e12bcfc9ed70c6af75f380928e21246e42af0870ee3a6475df5cc
DIST hyprland-0.37.1.gh.tar.gz 54651435 BLAKE2B 92bd78168909510ffb21b46f7d66e139e7b86f7655c7a8126eaf90b6ef6d7d5affaf0bc55ca1647a2f80b6d767afc00e1efe5f2241b2bc88d20357acee611b92 SHA512 f09316e210805b833a27524894222edc7a048b77f9f5d9cc8faa5b4e37040485ad3b9638f60a346da8d4d4aff24bbd6382b7fde64d07528990e9a521b2f46454
DIST hyprland-0.38.0.gh.tar.gz 54658884 BLAKE2B a0a26f59b0c4967cf58258adc719912855853fc54c5ebf55d42d34ca51905021ce4755eaaaf9c07ca1cabd0502d2a9c2e6bf6455bda10f36c2960b2525738416 SHA512 8452a0dab1c71c336201977318bb24442fe3ca08ae349e31b015f011bbb6d98aaf19dcfdcd31349c85ab837d6cda24dab40409469d0721d930e59aa7e2282153
diff --git a/gui-wm/hyprland/files/legacy-renderer-fix.patch b/gui-wm/hyprland/files/legacy-renderer-fix.patch
deleted file mode 100644
index a1ecbbd7ec5a..000000000000
--- a/gui-wm/hyprland/files/legacy-renderer-fix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-# https://github.com/hyprwm/Hyprland/pull/4928
-# https://bugs.gentoo.org/925912
-diff --git a/src/render/OpenGL.cpp b/src/render/OpenGL.cpp
-index 64f582f2..a6f2dc03 100644
---- a/src/render/OpenGL.cpp
-+++ b/src/render/OpenGL.cpp
-@@ -353,7 +353,11 @@ void CHyprOpenGLImpl::end() {
- // check for gl errors
- const GLenum ERR = glGetError();
-
-+#ifdef GLES2
-+ if (ERR == GL_CONTEXT_LOST_KHR) /* We don't have infra to recover from this */
-+#else
- if (ERR == GL_CONTEXT_LOST) /* We don't have infra to recover from this */
-+#endif
- RASSERT(false, "glGetError at Opengl::end() returned GL_CONTEXT_LOST. Cannot continue until proper GPU reset handling is implemented.");
- }
-
-@@ -2057,7 +2061,13 @@ void CHyprOpenGLImpl::createBGTextureForMonitor(CMonitor* pMonitor) {
- tex.m_vSize = IMAGESIZE * scale;
-
- // copy the data to an OpenGL texture we have
-- const GLint glIFormat = CAIROFORMAT == CAIRO_FORMAT_RGB96F ? GL_RGB32F : GL_RGBA;
-+ const GLint glIFormat = CAIROFORMAT == CAIRO_FORMAT_RGB96F ?
-+#ifdef GLES2
-+ GL_RGB32F_EXT :
-+#else
-+ GL_RGB32F :
-+#endif
-+ GL_RGBA;
- const GLint glFormat = CAIROFORMAT == CAIRO_FORMAT_RGB96F ? GL_RGB : GL_RGBA;
- const GLint glType = CAIROFORMAT == CAIRO_FORMAT_RGB96F ? GL_FLOAT : GL_UNSIGNED_BYTE;
-
diff --git a/gui-wm/hyprland/files/tty-freeze.patch b/gui-wm/hyprland/files/tty-freeze.patch
deleted file mode 100644
index 991593b8de86..000000000000
--- a/gui-wm/hyprland/files/tty-freeze.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/events/Misc.cpp b/src/events/Misc.cpp
-index b77cf038..eaaaec18 100644
---- a/src/events/Misc.cpp
-+++ b/src/events/Misc.cpp
-@@ -169,6 +169,7 @@ void Events::listener_sessionActive(wl_listener* listener, void* data) {
-
- for (auto& m : g_pCompositor->m_vMonitors) {
- g_pCompositor->scheduleFrameForMonitor(m.get());
-+ g_pHyprRenderer->applyMonitorRule(m.get(), &m->activeMonitorRule, true);
- }
-
- g_pConfigManager->m_bWantsMonitorReload = true;
diff --git a/gui-wm/hyprland/hyprland-0.35.0-r3.ebuild b/gui-wm/hyprland/hyprland-0.35.0-r3.ebuild
deleted file mode 100644
index 369ffc6eb951..000000000000
--- a/gui-wm/hyprland/hyprland-0.35.0-r3.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson toolchain-funcs
-
-DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
-HOMEPAGE="https://github.com/hyprwm/Hyprland"
-
-if [[ "${PV}" = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
-else
- SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}/${PN}-source"
-
- KEYWORDS="~amd64 ~riscv"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="X legacy-renderer systemd"
-
-# hyprpm (hyprland plugin manager) requires the dependencies at runtime
-# so that it can clone, compile and install plugins.
-HYPRPM_RDEPEND="
- app-alternatives/ninja
- dev-build/cmake
- dev-build/meson
- dev-vcs/git
- virtual/pkgconfig
-"
-# bundled wlroots has the following dependency string according to included headers.
-# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
-# enable x11-backend with X and vice versa
-WLROOTS_RDEPEND="
- >=dev-libs/libinput-1.14.0:=
- dev-libs/libliftoff
- >=dev-libs/wayland-1.22
- media-libs/libdisplay-info
- media-libs/libglvnd
- media-libs/mesa[egl(+),gles2]
- sys-apps/hwdata:=
- sys-auth/seatd:=
- >=x11-libs/libdrm-2.4.120
- x11-libs/libxkbcommon
- >=x11-libs/pixman-0.42.0
- virtual/libudev:=
- X? (
- x11-base/xwayland
- x11-libs/libxcb:0=
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-WLROOTS_DEPEND="
- >=dev-libs/wayland-protocols-1.32
-"
-WLROOTS_BDEPEND="
- dev-util/glslang
- dev-util/wayland-scanner
-"
-RDEPEND="
- ${HYPRPM_RDEPEND}
- ${WLROOTS_RDEPEND}
- dev-cpp/tomlplusplus
- dev-libs/glib:2
- dev-libs/libinput
- dev-libs/wayland
- media-libs/libglvnd
- x11-libs/cairo
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pango
- x11-libs/pixman
- X? (
- x11-libs/libxcb:0=
- )
-"
-DEPEND="
- ${RDEPEND}
- ${WLROOTS_DEPEND}
- dev-libs/hyprland-protocols
- dev-libs/wayland-protocols
-"
-BDEPEND="
- ${WLROOTS_BDEPEND}
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
- app-misc/jq
- dev-build/cmake
- dev-util/wayland-scanner
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/legacy-renderer-fix.patch"
- # https://bugs.gentoo.org/926259
- # https://github.com/hyprwm/Hyprland/issues/4839
- "${FILESDIR}/tty-freeze.patch"
-)
-
-pkg_setup() {
- [[ ${MERGE_TYPE} == binary ]] && return
-
- if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
- eerror "Hyprland requires >=sys-devel/gcc-13 to build"
- eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
- die "GCC version is too old to compile Hyprland!"
- elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
- eerror "Hyprland requires >=sys-devel/clang-16 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
- die "Clang version is too old to compile Hyprland!"
- fi
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature legacy-renderer legacy_renderer)
- $(meson_feature systemd)
- $(meson_feature X xwayland)
- $(meson_feature X wlroots:xwayland)
- -Dwlroots:backends=drm,libinput$(usev X ',x11')
- -Dwlroots:xcb-errors=disabled
- )
-
- meson_src_configure
-}
-
-src_install() {
- # First install everything except wlroots to avoid conflicts.
- meson_src_install --skip-subprojects wlroots
- # Then install development files (mainly wlroots) for bug #916760.
- meson_src_install --tags devel
-
- # Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
- # them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
- # Ideally you could override includedir per subproject and the install tags would
- # be granular enough to only install headers. But its not requiring this.
- mkdir "${ED}"/usr/include/hyprland/wlroots || die
- mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
- # devel tag includes wlroots .pc and .a files still
- rm -rf "${ED}"/usr/$(get_libdir)/ || die
-}
diff --git a/gui-wm/hyprland/hyprland-0.36.0-r2.ebuild b/gui-wm/hyprland/hyprland-0.36.0-r2.ebuild
deleted file mode 100644
index 7190982afaef..000000000000
--- a/gui-wm/hyprland/hyprland-0.36.0-r2.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson toolchain-funcs
-
-DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
-HOMEPAGE="https://github.com/hyprwm/Hyprland"
-
-if [[ "${PV}" = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
-else
- SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}/${PN}-source"
-
- KEYWORDS="~amd64 ~riscv"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="X legacy-renderer systemd"
-
-# hyprpm (hyprland plugin manager) requires the dependencies at runtime
-# so that it can clone, compile and install plugins.
-HYPRPM_RDEPEND="
- app-alternatives/ninja
- dev-build/cmake
- dev-build/meson
- dev-vcs/git
- virtual/pkgconfig
-"
-# bundled wlroots has the following dependency string according to included headers.
-# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
-# enable x11-backend with X and vice versa
-WLROOTS_RDEPEND="
- >=dev-libs/libinput-1.14.0:=
- dev-libs/libliftoff
- >=dev-libs/wayland-1.22
- media-libs/libdisplay-info
- media-libs/libglvnd
- media-libs/mesa[egl(+),gles2]
- sys-apps/hwdata:=
- sys-auth/seatd:=
- >=x11-libs/libdrm-2.4.118
- x11-libs/libxkbcommon
- >=x11-libs/pixman-0.42.0
- virtual/libudev:=
- X? (
- x11-base/xwayland
- x11-libs/libxcb:0=
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-WLROOTS_DEPEND="
- >=dev-libs/wayland-protocols-1.33
-"
-WLROOTS_BDEPEND="
- dev-util/glslang
- dev-util/wayland-scanner
-"
-RDEPEND="
- ${HYPRPM_RDEPEND}
- ${WLROOTS_RDEPEND}
- dev-cpp/tomlplusplus
- dev-libs/glib:2
- dev-libs/libinput
- dev-libs/wayland
- media-libs/libglvnd
- x11-libs/cairo
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pango
- x11-libs/pixman
- X? (
- x11-libs/libxcb:0=
- )
-"
-DEPEND="
- ${RDEPEND}
- ${WLROOTS_DEPEND}
- dev-libs/hyprland-protocols
- dev-libs/hyprlang
- >=dev-libs/wayland-protocols-1.25
-"
-BDEPEND="
- ${WLROOTS_BDEPEND}
- || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
- app-misc/jq
- dev-build/cmake
- dev-util/wayland-scanner
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/legacy-renderer-fix.patch"
- # https://bugs.gentoo.org/926259
- # https://github.com/hyprwm/Hyprland/issues/4839
- "${FILESDIR}/tty-freeze.patch"
-)
-
-pkg_setup() {
- [[ ${MERGE_TYPE} == binary ]] && return
-
- if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
- eerror "Hyprland requires >=sys-devel/gcc-13 to build"
- eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
- die "GCC version is too old to compile Hyprland!"
- elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
- eerror "Hyprland requires >=sys-devel/clang-16 to build"
- eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
- die "Clang version is too old to compile Hyprland!"
- fi
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature legacy-renderer legacy_renderer)
- $(meson_feature systemd)
- $(meson_feature X xwayland)
- $(meson_feature X wlroots:xwayland)
- -Dwlroots:backends=drm,libinput$(usev X ',x11')
- -Dwlroots:xcb-errors=disabled
- )
-
- meson_src_configure
-}
-
-src_install() {
- # First install everything except wlroots to avoid conflicts.
- meson_src_install --skip-subprojects wlroots
- # Then install development files (mainly wlroots) for bug #916760.
- meson_src_install --tags devel
-
- # Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
- # them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
- # Ideally you could override includedir per subproject and the install tags would
- # be granular enough to only install headers. But its not requiring this.
- mkdir "${ED}"/usr/include/hyprland/wlroots || die
- mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
- # devel tag includes wlroots .pc and .a files still
- rm -rf "${ED}"/usr/$(get_libdir)/ || die
-}