summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/wayfire/wayfire-0.7.5-r1.ebuild')
-rw-r--r--gui-wm/wayfire/wayfire-0.7.5-r1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild b/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild
index d2d80d37344a..eed7d341eeca 100644
--- a/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild
+++ b/gui-wm/wayfire/wayfire-0.7.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit meson toolchain-funcs
+inherit meson
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug +gles +system-wfconfig +system-wlroots X"
+IUSE="+gles +system-wfconfig +system-wlroots X"
DEPEND="
dev-libs/libinput:=
@@ -87,13 +87,8 @@ src_configure() {
$(meson_feature system-wlroots use_system_wlroots)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
- $(usex debug --buildtype=debug "")
- $(usex debug -Db_sanitize=address,undefined "")
)
- # Clang will fail to link without this
- tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
-
meson_src_configure
}