summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/wayfire/wayfire-0.8.0-r1.ebuild')
-rw-r--r--gui-wm/wayfire/wayfire-0.8.0-r1.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild b/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild
index 1fb2416c2bd8..21f177deca0c 100644
--- a/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson toolchain-funcs
+inherit meson
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="debug +gles +system-wfconfig +system-wlroots test X"
+IUSE="+gles +system-wfconfig +system-wlroots test X"
RESTRICT="!test? ( test )"
# bundled wlroots has the following dependency string according to included headers.
@@ -128,13 +128,8 @@ src_configure() {
$(meson_feature test tests)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
- $(usex debug --buildtype=debug "")
- $(usex debug -Db_sanitize=address,undefined "")
)
- # Clang will fail to link without this
- tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
-
meson_src_configure
}