summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/akonadi-calendar')
-rw-r--r--kde-apps/akonadi-calendar/Manifest1
-rw-r--r--kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/akonadi-calendar/Manifest b/kde-apps/akonadi-calendar/Manifest
index 7767153544a4..ead13d8a0706 100644
--- a/kde-apps/akonadi-calendar/Manifest
+++ b/kde-apps/akonadi-calendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-18.12.3.tar.xz 333656 BLAKE2B 039a132cf2e8dcc5935a4027b9e8b757b9b0060a3eb0e209dc87e8ee22b75117aa2f137c1c3508587b741de10cc466a7c5c9fae127e9bfbb59ea0870cdd4c5d4 SHA512 aac520c64a66fdeb27a2394e3eb7e4f4f30b123f4e9bf35cd01bf421d67c6dcdaa2041037e50474dd98b737c6ecbcd6c57f30e0a4ac7d2996ad18ed839288967
DIST akonadi-calendar-19.04.2.tar.xz 331748 BLAKE2B fb6c4831b6643b41d360b48274613c3f1d46786a8e7e5d0eb579bc44ca79f88d3a7407434235ef191b410cca77e7b2a88c627f58f99cea5571a4b3a7008d3182 SHA512 16beb855787754a8742345b7aba70daeb08efef5356e9245345f3094d6ae79970c14c830f1fd36a52d1b90d465f663ca43e1cb03cff82e465a987c678856cd84
+DIST akonadi-calendar-19.04.3.tar.xz 332632 BLAKE2B 928fc1ce338f90fa16378eddab3861aa49938f35d434259675362ca1a4461cfc7c4181f2c14f5b037be8f4e512ba917b3adb58440415c34c4a1c91259bab2c3c SHA512 b72b79c51d007669f637299a60dc246a363a9484f332983c348984e62e8e1dfd3f7808e6de9014efc09786f78a12bb705cf11193c32071aef7b916c7a4abc3e2
diff --git a/kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild b/kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild
new file mode 100644
index 000000000000..c2875fb209bf
--- /dev/null
+++ b/kde-apps/akonadi-calendar/akonadi-calendar-19.04.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library for akonadi calendar integration"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !<kde-apps/kdepim-runtime-18.03.80
+"
+
+RESTRICT+=" test"