summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/akonadi')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-18.12.3-r2.ebuild118
-rw-r--r--kde-apps/akonadi/files/akonadi-18.12.3-akonadi_control-start-race-condition.patch187
-rw-r--r--kde-apps/akonadi/files/akonadi-18.12.3-collection-detach-at-wrong-time-in-attribute.patch97
-rw-r--r--kde-apps/akonadi/files/akonadi-18.12.3-major-regression-updating-attributes.patch55
5 files changed, 0 insertions, 458 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index 7616a0ed6d4b..9f03a6d7e2e3 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1,2 +1 @@
-DIST akonadi-18.12.3.tar.xz 1555044 BLAKE2B 20eb8cf2027c1589e65ef4d907f6252faaedc7ab48c45be79bf66b5f9ae9652cbf654d00261f4a09765edaa0b0c03c798ee079796d902de4f522e5d0cfce5491 SHA512 f97e716be612001a8176f20afbe80a1cf4c78c6d348d92e542307ea951e1ff74189d2f0847675ed44ad65845b52a5180346b3866f5a8d82b55ed613d107ac346
DIST akonadi-19.04.3.tar.xz 1574868 BLAKE2B f520f5e8f8fc6480b6e44d6f91c561317b2d3460072c5473baccdf149c0e9eca5587cfeefaeacee0e504349624418a0ba5de7042866c0f5806de0b677f8f38a1 SHA512 62d7367ef87cd6fd7e26ae87dcc15df427f3b647618334a5ae67e722ca16dc2c7882152bd6172ab6a0982979f45271f6d65cc15b18f86e8a0ebf144b1bbe576a
diff --git a/kde-apps/akonadi/akonadi-18.12.3-r2.ebuild b/kde-apps/akonadi/akonadi-18.12.3-r2.ebuild
deleted file mode 100644
index 78b5d5374581..000000000000
--- a/kde-apps/akonadi/akonadi-18.12.3-r2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-KDE_DESIGNERPLUGIN="true"
-KDE_TEST="forceoptional"
-VIRTUALDBUS_TEST="true"
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Storage service for PIM data and libraries for PIM apps"
-HOMEPAGE="https://community.kde.org/KDE_PIM/akonadi"
-
-KEYWORDS="amd64 ~arm ~arm64 x86"
-LICENSE="LGPL-2.1+"
-IUSE="+mysql postgres sqlite tools xml"
-
-REQUIRED_USE="|| ( mysql postgres sqlite ) test? ( tools )"
-
-COMMON_DEPEND="
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kitemmodels)
- $(add_frameworks_dep kitemviews)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtsql 'mysql?,postgres?')
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtxml)
- sqlite? (
- $(add_qt_dep qtsql 'sqlite' '' '5=')
- dev-db/sqlite:3
- )
- xml? ( dev-libs/libxml2 )
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/boost
- dev-libs/libxslt
- test? ( sys-apps/dbus )
-"
-RDEPEND="${COMMON_DEPEND}
- !kde-apps/akonadi:4
- !<kde-apps/kapptemplate-17.11.80
- !kde-apps/kdepim-l10n
- !kde-apps/kdepimlibs
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
-"
-
-# some akonadi tests time out, that probably needs more work as it's ~700 tests
-RESTRICT+=" test"
-
-PATCHES=(
- "${FILESDIR}/${PN}-18.12.2-mysql56-crash.patch"
- "${FILESDIR}/${P}-major-regression-updating-attributes.patch"
- "${FILESDIR}/${P}-collection-detach-at-wrong-time-in-attribute.patch"
- "${FILESDIR}/${P}-akonadi_control-start-race-condition.patch"
-)
-
-pkg_setup() {
- # Set default storage backend in order: MySQL, PostgreSQL, SQLite
- # reverse driver check to keep the order
- use sqlite && DRIVER="QSQLITE3"
- use postgres && DRIVER="QPSQL"
- use mysql && DRIVER="QMYSQL"
-
- if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
- ewarn "We strongly recommend you change your Akonadi database backend to either MySQL"
- ewarn "or PostgreSQL in your user configuration."
- ewarn "In particular, kde-apps/kmail does not work properly with the sqlite backend."
- fi
-
- kde5_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
- -DBUILD_TOOLS=$(usex tools)
- $(cmake-utils_use_find_package xml LibXml2)
- )
-
- kde5_src_configure
-}
-
-src_install() {
- # Who knows, maybe it accidentally fixes our permission issues
- cat <<-EOF > "${T}"/akonadiserverrc
-[%General]
-Driver=${DRIVER}
-EOF
- insinto /usr/share/config/akonadi
- doins "${T}"/akonadiserverrc
-
- kde5_src_install
-}
-
-pkg_postinst() {
- kde5_pkg_postinst
- elog "You can select the storage backend in ~/.config/akonadi/akonadiserverrc."
- elog "Available drivers are:"
- use mysql && elog " QMYSQL"
- use postgres && elog " QPSQL"
- use sqlite && elog " QSQLITE3"
- elog "${DRIVER} has been set as your default akonadi storage backend."
-}
diff --git a/kde-apps/akonadi/files/akonadi-18.12.3-akonadi_control-start-race-condition.patch b/kde-apps/akonadi/files/akonadi-18.12.3-akonadi_control-start-race-condition.patch
deleted file mode 100644
index dd3aac5f58c3..000000000000
--- a/kde-apps/akonadi/files/akonadi-18.12.3-akonadi_control-start-race-condition.patch
+++ /dev/null
@@ -1,187 +0,0 @@
-From c21bb5220a3ae835a5183afd58c186ba21f6c93d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
-Date: Fri, 28 Jun 2019 17:10:04 +0200
-Subject: Fix race-condition on akonadi_control start
-
-Summary:
-Check that there are no other akonadi_control instances running as the
-very first thing on startup. Previously this check would happen after
-AkApplication initialization, which contains some potential race-
-conditions, like rotating log files.
-
-The situation when akonadi_control is launched multiple times can occur
-on session startup, when multiple different components will attempt to
-launch Akonadi if its not yet running.
-
-BUG: 392092
-FIXED-IN: 19.04.3
-
-Reviewers: #kde_pim, vkrause
-
-Reviewed By: #kde_pim, vkrause
-
-Subscribers: kde-pim
-
-Tags: #kde_pim
-
-Differential Revision: https://phabricator.kde.org/D22092
----
- src/akonadicontrol/main.cpp | 16 ++-------------
- src/shared/akapplication.cpp | 7 +++----
- src/shared/akapplication.h | 49 ++++++++++++++++++++++++++++++++++++++------
- 3 files changed, 48 insertions(+), 24 deletions(-)
-
-diff --git a/src/akonadicontrol/main.cpp b/src/akonadicontrol/main.cpp
-index 19bebb8..7dba85b 100644
---- a/src/akonadicontrol/main.cpp
-+++ b/src/akonadicontrol/main.cpp
-@@ -52,7 +52,7 @@ void crashHandler(int)
-
- int main(int argc, char **argv)
- {
-- AkGuiApplication app(argc, argv, AKONADICONTROL_LOG());
-+ AkUniqueGuiApplication app(argc, argv, Akonadi::DBus::serviceName(Akonadi::DBus::ControlLock), AKONADICONTROL_LOG());
- app.setDescription(QStringLiteral("Akonadi Control Process\nDo not run this manually, use 'akonadictl' instead to start/stop Akonadi."));
-
- KAboutData aboutData(QStringLiteral("akonadi_control"),
-@@ -64,20 +64,8 @@ int main(int argc, char **argv)
-
- app.parseCommandLine();
-
-- // try to acquire the lock first, that means there is no second instance trying to start up at the same time
-- // registering the real service name happens in AgentManager::continueStartup(), when everything is in fact up and running
-- if (!QDBusConnection::sessionBus().registerService(Akonadi::DBus::serviceName(Akonadi::DBus::ControlLock))) {
-- // We couldn't register. Most likely, it's already running.
-- const QString lastError = QDBusConnection::sessionBus().lastError().message();
-- if (lastError.isEmpty()) {
-- qCWarning(AKONADICONTROL_LOG) << "Unable to register service as" << Akonadi::DBus::serviceName(Akonadi::DBus::ControlLock) << "Maybe it's already running?";
-- } else {
-- qCWarning(AKONADICONTROL_LOG) << "Unable to register service as" << Akonadi::DBus::serviceName(Akonadi::DBus::ControlLock) << "Error was:" << lastError;
-- }
-- return -1;
-- }
--
- // older Akonadi server versions don't use the lock service yet, so check if one is already running before we try to start another one
-+ // TODO: Remove this legacy check?
- if (QDBusConnection::sessionBus().interface()->isServiceRegistered(Akonadi::DBus::serviceName(Akonadi::DBus::Control))) {
- qCWarning(AKONADICONTROL_LOG) << "Another Akonadi control process is already running.";
- return -1;
-diff --git a/src/shared/akapplication.cpp b/src/shared/akapplication.cpp
-index af860e5..b790b8d 100644
---- a/src/shared/akapplication.cpp
-+++ b/src/shared/akapplication.cpp
-@@ -32,10 +32,9 @@
-
- AkApplicationBase *AkApplicationBase::sInstance = nullptr;
-
--AkApplicationBase::AkApplicationBase(int &argc, char **argv, const QLoggingCategory &loggingCategory)
-+AkApplicationBase::AkApplicationBase(std::unique_ptr<QCoreApplication> app, const QLoggingCategory &loggingCategory)
- : QObject(nullptr)
-- , mArgc(argc)
-- , mArgv(argv)
-+ , mApp(std::move(app))
- , mLoggingCategory(loggingCategory)
- {
- Q_ASSERT(!sInstance);
-@@ -59,7 +58,7 @@ AkApplicationBase *AkApplicationBase::instance()
-
- void AkApplicationBase::init()
- {
-- akInit(QString::fromLatin1(mArgv[0]));
-+ akInit(mApp->applicationName());
- akInitRemoteLog();
-
- if (!QDBusConnection::sessionBus().isConnected()) {
-diff --git a/src/shared/akapplication.h b/src/shared/akapplication.h
-index aae7a99..433b725 100644
---- a/src/shared/akapplication.h
-+++ b/src/shared/akapplication.h
-@@ -23,6 +23,10 @@
- #include <QObject>
- #include <QCommandLineParser>
- #include <QLoggingCategory>
-+#include <QDBusConnection>
-+#include <QDBusError>
-+
-+#include <memory>
-
- class QCoreApplication;
- class QApplication;
-@@ -55,16 +59,15 @@ public:
- int exec();
-
- protected:
-- AkApplicationBase(int &argc, char **argv, const QLoggingCategory &loggingCategory);
-+ AkApplicationBase(std::unique_ptr<QCoreApplication> app, const QLoggingCategory &loggingCategory);
- void init();
-- QScopedPointer<QCoreApplication> mApp;
-+
-+ std::unique_ptr<QCoreApplication> mApp;
-
- private Q_SLOTS:
- void pollSessionBus() const;
-
- private:
-- int mArgc;
-- char **mArgv;
- QString mInstanceId;
- const QLoggingCategory &mLoggingCategory;
- static AkApplicationBase *sInstance;
-@@ -77,13 +80,46 @@ class AkApplicationImpl : public AkApplicationBase
- {
- public:
- AkApplicationImpl(int &argc, char **argv, const QLoggingCategory &loggingCategory = *QLoggingCategory::defaultCategory())
-- : AkApplicationBase(argc, argv, loggingCategory)
-+ : AkApplicationBase(std::make_unique<T>(argc, argv), loggingCategory)
- {
-- mApp.reset(new T(argc, argv));
- init();
- }
- };
-
-+template<typename T>
-+class AkUniqueApplicationImpl : public AkApplicationBase
-+{
-+public:
-+ AkUniqueApplicationImpl(int &argc, char **argv, const QString &serviceName, const QLoggingCategory &loggingCategory = *QLoggingCategory::defaultCategory())
-+ : AkApplicationBase(std::make_unique<T>(argc, argv), loggingCategory)
-+ {
-+ registerUniqueServiceOrTerminate(serviceName, loggingCategory);
-+ init();
-+ }
-+
-+private:
-+ void registerUniqueServiceOrTerminate(const QString &serviceName, const QLoggingCategory &log)
-+ {
-+ auto bus = QDBusConnection::sessionBus();
-+ if (!bus.isConnected()) {
-+ qCCritical(log, "Session bus not found. Is DBus running?");
-+ exit(1);
-+ }
-+
-+ if (!bus.registerService(serviceName)) {
-+ // We couldn't register. Most likely, it's already running.
-+ const QString lastError = bus.lastError().message();
-+ if (lastError.isEmpty()) {
-+ qCInfo(log, "Service %s already registered, terminating now.", qUtf8Printable(serviceName));
-+ exit(0); // already running, so it's OK. Terminate now.
-+ } else {
-+ qCCritical(log, "Unable to register service as %s due to an error: %s", qUtf8Printable(serviceName), qUtf8Printable(lastError));
-+ exit(1); // :(
-+ }
-+ }
-+ }
-+};
-+
- /**
- * Returns the contents of @p name environment variable if it is defined,
- * or @p defaultValue otherwise.
-@@ -93,5 +129,6 @@ QString akGetEnv(const char *name, const QString &defaultValue = QString());
- typedef AkApplicationImpl<QCoreApplication> AkCoreApplication;
- typedef AkApplicationImpl<QApplication> AkApplication;
- typedef AkApplicationImpl<QGuiApplication> AkGuiApplication;
-+typedef AkUniqueApplicationImpl<QGuiApplication> AkUniqueGuiApplication;
-
- #endif
---
-cgit v1.1
diff --git a/kde-apps/akonadi/files/akonadi-18.12.3-collection-detach-at-wrong-time-in-attribute.patch b/kde-apps/akonadi/files/akonadi-18.12.3-collection-detach-at-wrong-time-in-attribute.patch
deleted file mode 100644
index bee866dc3bc7..000000000000
--- a/kde-apps/akonadi/files/akonadi-18.12.3-collection-detach-at-wrong-time-in-attribute.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From 53ad3b6d73d92ea289cf0183c10e2b8a35c8127a Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Thu, 21 Mar 2019 23:37:36 +0100
-Subject: Fix collection detaching at the wrong time in attribute()
-
-Summary:
-Found in FatCRM where changes to collection attributes were not stored
-anymore.
-
-Test Plan:
-New unittest to ensure that we get the attribute from the
-detached collection, not from the original one.
-
-Reviewers: dvratil
-
-Reviewed By: dvratil
-
-Subscribers: kde-pim
-
-Tags: #kde_pim
-
-Differential Revision: https://phabricator.kde.org/D19741
----
- autotests/libs/collectionattributetest.cpp | 15 +++++++++++++++
- autotests/libs/collectionattributetest.h | 1 +
- src/core/collection.h | 8 ++------
- 3 files changed, 18 insertions(+), 6 deletions(-)
-
-diff --git a/autotests/libs/collectionattributetest.cpp b/autotests/libs/collectionattributetest.cpp
-index e264a37..9c46561 100644
---- a/autotests/libs/collectionattributetest.cpp
-+++ b/autotests/libs/collectionattributetest.cpp
-@@ -240,3 +240,18 @@ void CollectionAttributeTest::testCollectionIdentificationAttribute()
- QCOMPARE(parsed.identifier(), id);
- QCOMPARE(parsed.collectionNamespace(), ns);
- }
-+
-+void CollectionAttributeTest::testDetach()
-+{
-+ // GIVEN a collection with an attribute
-+ Collection col;
-+ col.attribute<TestAttribute>(Akonadi::Collection::AddIfMissing);
-+ Collection col2 = col; // and a copy, so that non-const access detaches
-+
-+ // WHEN
-+ TestAttribute *attr = col2.attribute<TestAttribute>(Akonadi::Collection::AddIfMissing);
-+ TestAttribute *attr2 = col2.attribute<TestAttribute>();
-+
-+ // THEN
-+ QCOMPARE(attr, attr2);
-+}
-diff --git a/autotests/libs/collectionattributetest.h b/autotests/libs/collectionattributetest.h
-index 420df78..2afa9eb 100644
---- a/autotests/libs/collectionattributetest.h
-+++ b/autotests/libs/collectionattributetest.h
-@@ -32,6 +32,7 @@ private Q_SLOTS:
- void testDefaultAttributes();
- void testCollectionRightsAttribute();
- void testCollectionIdentificationAttribute();
-+ void testDetach();
- };
-
- #endif
-diff --git a/src/core/collection.h b/src/core/collection.h
-index b5a496c..9c19cc9 100644
---- a/src/core/collection.h
-+++ b/src/core/collection.h
-@@ -565,10 +565,10 @@ inline T *Akonadi::Collection::attribute(Collection::CreateOption option)
- Q_UNUSED(option);
-
- const T dummy;
-+ markAttributesChanged();
- if (hasAttribute(dummy.type())) {
- T *attr = dynamic_cast<T *>(attribute(dummy.type()));
- if (attr) {
-- markAttributesChanged();
- return attr;
- }
- //Reuse 5250
-@@ -585,14 +585,10 @@ template <typename T>
- inline T *Akonadi::Collection::attribute() const
- {
- const QByteArray type = T().type();
-+ const_cast<Collection*>(this)->markAttributesChanged();
- if (hasAttribute(type)) {
- T *attr = dynamic_cast<T *>(attribute(type));
- if (attr) {
-- // FIXME: This method returns a non-const pointer, so callers may still modify the
-- // attribute. Unfortunately, just making this function return a const pointer and
-- // creating a non-const overload does not work, as many users of this function abuse the
-- // non-const pointer and modify the attribute even on a const object.
-- const_cast<Collection*>(this)->markAttributesChanged();
- return attr;
- }
- //reuse 5250
---
-cgit v1.1
diff --git a/kde-apps/akonadi/files/akonadi-18.12.3-major-regression-updating-attributes.patch b/kde-apps/akonadi/files/akonadi-18.12.3-major-regression-updating-attributes.patch
deleted file mode 100644
index c3e62af2d02a..000000000000
--- a/kde-apps/akonadi/files/akonadi-18.12.3-major-regression-updating-attributes.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 1d8851495bcfa6ff5d3fa35882b68fdf68b21a7f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
-Date: Thu, 21 Mar 2019 13:22:58 +0100
-Subject: Fix a regression when updating attributes
-
-This fixes a regression introduced in 3a062e6a and 6054e42d where some
-attributes were not sent to the Akonadi server in update job even though
-they were modified. This was due to a bad API design which returns a
-non-const pointer to an attribute from a const method, so callers sometimes
-modify the returned attribute on a const object. Since the method itself
-is const though, it did not mark the attribute as modified.
-
-Proper fix is to introduce a purely const and non-const overloads for
-the attribute accessors, unfortunatelly this requires fixing a lot of our code
-in many places first to not abuse the non-constness of the returned
-attribute.
-
-Note that since the code is in an inlined method, all clients should be
-recompiled.
-
-CCMAIL: faure@kde.org
----
- src/core/collection.h | 13 +++++++++----
- 1 file changed, 9 insertions(+), 4 deletions(-)
-
-diff --git a/src/core/collection.h b/src/core/collection.h
-index 50c0926..b5a496c 100644
---- a/src/core/collection.h
-+++ b/src/core/collection.h
-@@ -584,14 +584,19 @@ inline T *Akonadi::Collection::attribute(Collection::CreateOption option)
- template <typename T>
- inline T *Akonadi::Collection::attribute() const
- {
-- const T dummy;
-- if (hasAttribute(dummy.type())) {
-- T *attr = dynamic_cast<T *>(attribute(dummy.type()));
-+ const QByteArray type = T().type();
-+ if (hasAttribute(type)) {
-+ T *attr = dynamic_cast<T *>(attribute(type));
- if (attr) {
-+ // FIXME: This method returns a non-const pointer, so callers may still modify the
-+ // attribute. Unfortunately, just making this function return a const pointer and
-+ // creating a non-const overload does not work, as many users of this function abuse the
-+ // non-const pointer and modify the attribute even on a const object.
-+ const_cast<Collection*>(this)->markAttributesChanged();
- return attr;
- }
- //reuse 5250
-- qWarning() << "Found attribute of unknown type" << dummy.type()
-+ qWarning() << "Found attribute of unknown type" << type
- << ". Did you forget to call AttributeFactory::registerAttribute()?";
- }
-
---
-cgit v1.1