summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-16.12.1-r1.ebuild74
-rw-r--r--kde-apps/ark/files/ark-16.12.1-fix-crash.patch21
3 files changed, 0 insertions, 96 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 7833b3d4e35b..d059e7ec5255 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,3 +1,2 @@
DIST ark-16.08.3.tar.xz 1293460 SHA256 c713f6afe0784229796e14ef6e67a1afb5f276a97651bd2a973eff22f8932c08 SHA512 80cecfce8ff417c68f3d0a4e0bf2467d7345fc9d90c4f8b93bb66b09624ea40283aa6f84bd75843d9fe92b6fdbb018117feec5835fa87aca0f21b3e8a02b8abd WHIRLPOOL 9f80598d2a087fc16b023bdf55210114513b0f7c2a446b96f158533a9ca73f2c335fa20d2ada5d6569a860cc6b1625476b5016df5fa9622d4d9395d36f79f0a2
-DIST ark-16.12.1.tar.xz 1348404 SHA256 b54c137098bbf77d99a54e526a58a83aca73db1cf1fabbbc4bccdf09a1bee8d0 SHA512 4bf66233810cf2ca61bcec3b64e50dec37d2d9b35bcf96b41c3ba10ba14aa90b01e13ff1535f98773e7be54d1d42654733cd63c76c2823b093284bb3e7ca4c77 WHIRLPOOL 88f5f1058a20c52084d472ae019a8eff68fbdc6a42a9ef97a8537b9864d85ec27903b586379d6cb15c54e3d0235d5b96dd77203a628dca5d4511b6353b88fa07
DIST ark-16.12.2.tar.xz 1348476 SHA256 23d346f331de8d3bce14ce073244f79f99321bf59c037e3a229d398b6511571e SHA512 c4cb7c8e89e75cefe99eeaa495b4d0ec8c9082cf34f768cdbe9f268c511d71f4d8173141b7999077b232e74181402f726f37cdabfe31b2fce22b7457c5faf535 WHIRLPOOL e43f0543cc809b67f2cc17cf3c7fead040352c0e9537e43e528c4ab9dcbe3b5d7c8dc609929d10299fec29fd21636ffd37a408d3940d27eb541c86771fad5dd3
diff --git a/kde-apps/ark/ark-16.12.1-r1.ebuild b/kde-apps/ark/ark-16.12.1-r1.ebuild
deleted file mode 100644
index 8fdad666ece8..000000000000
--- a/kde-apps/ark/ark-16.12.1-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-KDE_HANDBOOK="forceoptional"
-KDE_TEST="optional"
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="KDE Archiving tool"
-HOMEPAGE="https://www.kde.org/applications/utilities/ark
-https://utils.kde.org/projects/ark"
-KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 lzma zlib"
-
-RDEPEND="
- $(add_frameworks_dep karchive)
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kjobwidgets)
- $(add_frameworks_dep kparts)
- $(add_frameworks_dep kpty)
- $(add_frameworks_dep kservice)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- app-arch/libarchive:=[bzip2?,lzma?,zlib?]
-"
-DEPEND="${RDEPEND}
- $(add_qt_dep qtconcurrent)
- sys-devel/gettext
-"
-
-# bug #560548, last checked with 16.04.1
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}/${P}-fix-crash.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package bzip2 BZip2)
- $(cmake-utils_use_find_package lzma LibLZMA)
- $(cmake-utils_use_find_package zlib ZLIB)
- )
-
- kde5_src_configure
-}
-
-pkg_postinst() {
- kde5_pkg_postinst
-
- if ! has_version app-arch/unar ; then
- elog "For handling rar archives, install app-arch/unar"
- fi
-
- if ! has_version app-arch/p7zip ; then
- elog "For handling 7-Zip archives, install app-arch/p7zip"
- fi
-
- if ! has_version app-arch/lrzip ; then
- elog "For handling lrz archives, install app-arch/lrzip"
- fi
-}
diff --git a/kde-apps/ark/files/ark-16.12.1-fix-crash.patch b/kde-apps/ark/files/ark-16.12.1-fix-crash.patch
deleted file mode 100644
index b416783de684..000000000000
--- a/kde-apps/ark/files/ark-16.12.1-fix-crash.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-commit b5e59a044d392ede62af23076bbf0a154d00bf60
-Author: Elvis Angelaccio <elvis.angelaccio@kde.org>
-Date: Fri Jan 13 16:14:35 2017 +0100
-
- Stop crashing when loading the konqueror's webengine part
-
- QtWebEngine requires this attribute set before the QGuiApplication
- instance is created.
-
-diff --git a/app/main.cpp b/app/main.cpp
-index d375d79..d3a60b1 100644
---- a/app/main.cpp
-+++ b/app/main.cpp
-@@ -42,6 +42,7 @@ using Kerfuffle::AddToArchive;
-
- int main(int argc, char **argv)
- {
-+ QCoreApplication::setAttribute(Qt::AA_ShareOpenGLContexts); // Required for the webengine part.
- QApplication application(argc, argv);
-
- /**