summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-19.08.3.ebuild109
-rw-r--r--kde-apps/cantor/metadata.xml1
3 files changed, 111 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index 16bedc442186..58a4e0ea012b 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1 +1,2 @@
+DIST cantor-19.08.3.tar.xz 2538816 BLAKE2B e2445835eb6ffb368b50fab2089642a28ee3548bf572d3265b152696a4d45e1deb984793bae2819361132097f5dd19ea98ddcd7643c3675a8fd7c3f2fe3518a0 SHA512 1dc545c2c122d0303d418c757d7f4079250354e4326f2ec0d4796de343d00beb580ab47945ecc6ea491f4cd893bbfe6fced7eeb0ab8e3122000b4c75912ca807
DIST cantor-19.12.3.tar.xz 9014164 BLAKE2B d88c820a36806facc76197ba2e29fece503fba2e3bafe5d856c64243b6d098babc4ae6da082e7c07f20b499f9ed2373aeccfbb5dcede196214d8a2c582de302a SHA512 83324f7a1702b5ed5d74ecab7664b653b8f318b03b6c856c7a70133b2aaf0927cf8b16a8ba9e27a7224d4d8d5900f1dcdbc89e70f40871f000db29f6f072668a
diff --git a/kde-apps/cantor/cantor-19.08.3.ebuild b/kde-apps/cantor/cantor-19.08.3.ebuild
new file mode 100644
index 000000000000..cb26616f4f8c
--- /dev/null
+++ b/kde-apps/cantor/cantor-19.08.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{6,7} )
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://kde.org/applications/education/cantor https://edu.kde.org/cantor/"
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="arm64"
+IUSE="+analitza julia lua markdown postscript python qalculate R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+ analitza? ( >=kde-apps/analitza-${PVCUT}:5 )
+ julia? ( dev-lang/julia )
+ lua? ( dev-lang/luajit:2 )
+ markdown? ( >=app-text/discount-2.2.2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate:=
+ )
+ postscript? ( app-text/libspectre )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-qt/qtdbus-${QTMIN}:5
+ )
+ R? ( dev-lang/R )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT+=" test"
+
+pkg_pretend() {
+ ecm_pkg_pretend
+
+ if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
+ ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
+ elog "You have decided to build ${PN} with no backend."
+ elog "To have this application functional, please enable one of the backends via USE flag:"
+ elog " analitza, lua, python, qalculate, R"
+ elog "Alternatively, install one of these:"
+ elog " # emerge sci-mathematics/maxima (bug #619534)"
+ elog " # emerge sci-mathematics/octave"
+ elog "Experimental available USE flag:"
+ elog " julia (not stable, bug #613576)"
+ elog
+ fi
+
+ if ! has_version virtual/latex-base; then
+ elog "For LaTeX support:"
+ elog " # emerge virtual/latex-base"
+ fi
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ use julia && addpredict /proc/self/mem # bug 602894
+
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonLibs=ON
+ $(cmake_use_find_package analitza Analitza5)
+ $(cmake_use_find_package julia Julia)
+ $(cmake_use_find_package lua LuaJIT)
+ $(cmake_use_find_package markdown Discount)
+ $(cmake_use_find_package postscript LibSpectre)
+ $(cmake_use_find_package python PythonLibs3)
+ $(cmake_use_find_package qalculate Qalculate)
+ $(cmake_use_find_package R R)
+ )
+ ecm_src_configure
+}
diff --git a/kde-apps/cantor/metadata.xml b/kde-apps/cantor/metadata.xml
index 20e3a5914aa1..23b2f303adc2 100644
--- a/kde-apps/cantor/metadata.xml
+++ b/kde-apps/cantor/metadata.xml
@@ -9,6 +9,7 @@
<flag name="analitza">Enable <pkg>kde-apps/analitza</pkg> backend support</flag>
<flag name="julia">Enable <pkg>dev-lang/julia</pkg> backend support</flag>
<flag name="qalculate">Enable <pkg>sci-libs/libqalculate</pkg> backend support</flag>
+ <flag name="markdown">Enable Markdown support via <pkg>app-text/discount</pkg></flag>
<flag name="R">Enable <pkg>dev-lang/R</pkg> backend support</flag>
</use>
</pkgmetadata>