summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kcontrol/kcontrol-15.12.3.ebuild')
-rw-r--r--kde-apps/kcontrol/kcontrol-15.12.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-apps/kcontrol/kcontrol-15.12.3.ebuild b/kde-apps/kcontrol/kcontrol-15.12.3.ebuild
new file mode 100644
index 000000000000..a88fee4955d3
--- /dev/null
+++ b/kde-apps/kcontrol/kcontrol-15.12.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Control Center"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdeapps_dep zeroconf-ioslave)
+ || ( $(add_kdebase_dep khotkeys '' 4.11) kde-plasma/khotkeys )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+ if use handbook; then
+ sed -i -e "/add_subdirectory(kcm_ssl)/d" doc/kcontrol/CMakeLists.txt || die
+ sed -i -e "/add_subdirectory(trash)/d" doc/kcontrol/CMakeLists.txt || die
+ fi
+}