summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/Manifest1
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-18.04.2.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/Manifest b/kde-apps/kdepim-runtime/Manifest
index 278ba3ec9272..013cbcfae6b8 100644
--- a/kde-apps/kdepim-runtime/Manifest
+++ b/kde-apps/kdepim-runtime/Manifest
@@ -1,2 +1,3 @@
DIST kdepim-runtime-17.12.3.tar.xz 1796892 BLAKE2B 8e74409e6a5eee9201340f971f14324eee68d1510c23f2684686a3e8b8463031cfd6658de2073f1205f8c6f7207d1f1dabbddcfad05c87fa7c8665dd30566bfa SHA512 9ddb7c717a94ca75f561e54f7842c18c2def83c129f004e345a32ab4de4a5b4b15ec50f2044000d785572636a0d78adc4d90f9b3550ed853cf1982c6ef749aa7
DIST kdepim-runtime-18.04.1.tar.xz 1749484 BLAKE2B 7b1e2654522e15f881e9fb2429387af31f7a46978f367d5183fdf5b2fa119e120a493a768c8a88cd159af5e2922316147031268ce45094a7afa9849edaa35428 SHA512 b9aed0799eb6bd6c0c21c1d8588b84f460a793b46f9cf79381d2f7c8a43a6fcac658c0a887ad7fd62ba7224c8b014c03aed7209a952c6d2814fccb1a3c24e769
+DIST kdepim-runtime-18.04.2.tar.xz 1751204 BLAKE2B 206830dbc56c12924ac6556711d486cc29d83f945582520c4fe9b5b101b788122a56e277ab16bbf7c7d2acd0063749fd2a86c1196e7e2558d6a0033175350c93 SHA512 649a9f9ca2ce0c51a3223ce46a8facb76c6c60447d69648301abf4fb1e5f3b72190812c5f09ee5e4e2faa440680ec661264390238a71c6f1074a03aff3041b1d
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-18.04.2.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-18.04.2.ebuild
new file mode 100644
index 000000000000..4f1d61f160a7
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-18.04.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+# TODO kolab
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kholidays)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkgapi)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libxslt
+ test? ( $(add_kdeapps_dep kimap 'test') )
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-misc/akonadi-ews
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}