summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-18.08.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index f3ec142b7b7f..1b8dc3af14e4 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1 +1,2 @@
DIST ksystemlog-18.04.3.tar.xz 1784680 BLAKE2B 27f71ffb37ab30311cb638f1ed03a1ff0a78c92117c0452f1797c0b01cc1c816763b6ecb7295f22118747ad85856b64399d04a02447ca4766cde598385ad3ff0 SHA512 f42d7fdabd93f98180077388ff4fc93921db562795edaa1892dd4526a8f8637a2f5ed5c063c0b97f96603a0f0f2f0425336c61b956c9ba933cec565fb2cad827
+DIST ksystemlog-18.08.1.tar.xz 1966736 BLAKE2B 0a913d3bf663078fcacb7709fcc06728ca7dc0ea6269b4815021b92d84457e9357e6e0107db1e5339b7fe60cda18fc8262d8560fa177b9d574fdcc8b766d00a8 SHA512 096c335bc4b461548d7d16dbee738ee06fb5fae91ab3f02869b73af18f1dd8ef4ea27568a265e6a40f3777e7749e9f5a11e9b3402ac5f698836e00475a759308
diff --git a/kde-apps/ksystemlog/ksystemlog-18.08.1.ebuild b/kde-apps/ksystemlog/ksystemlog-18.08.1.ebuild
new file mode 100644
index 000000000000..613a2eccdf4d
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-18.08.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}