summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.41.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 98bda96762f8..41f2a98dfb91 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.37.0.tar.xz 1752004 BLAKE2B 0e1dd3cbbae3034dfc690c38d853dcb4e582b04113720e8180961fa625aa3e1335a3c00147a0a25d2767fe1d9d3708bb89e1db879c396a2e050367f162522e8a SHA512 ecff45b2d7138621b19b9b276c4a2d7940c156ee81d85789d598178179e524ed6fef014c9d6615b91d2ea9c4c9a058d5009f44899834c541c36301f9ca581dd7
DIST frameworkintegration-5.40.0.tar.xz 1752732 BLAKE2B 8c5e10a9a295ec89092fcba9fbc6ecaa715fdb5a681e351ef46ce23e6600b665b3d46047774e325c642cdc7de950a2dc32a06e4bdb1f417c8791ae0dfadf8231 SHA512 2ef108ca6738c4f9f9d164bd79449a4baaf9d343916f9fad98925ea0bb1ac5bed57fbe239f2ae8d1ab8ecf251dc3329e7e96ce0f9c55e607d0bbf5c59c697e28
+DIST frameworkintegration-5.41.0.tar.xz 1752828 BLAKE2B c16513b84703f4a1a8f2efc4433e7ed215517230cc967363415f7c003288a31a194dab317c30ff3a63c5dc8fd2e3e41c1c22851a62bd92d02a74fcc693e19b90 SHA512 aa0c5b98bbfb287a850145c760d116c6d7d61d0a3ec966ebec27ebe27a82ab65e71e5d3f12702c0bd927ba07d9ad07874cddebc947ed073afe514d73e83ef402
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.41.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.41.0.ebuild
new file mode 100644
index 000000000000..9062d6d3800d
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.41.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}