summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.55.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 1fdfe5d757f3..1fd205c04551 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.54.0.tar.xz 1753080 BLAKE2B 267d6a7692d8d63ca19bf819955cb194c103eb996c0d144e4fa06f2bb5ca9c3a7b80084f4eb23ba94c69fc0004f5c7e5d7c6738b4108b7886903077e1312731f SHA512 9bb0c8a10b342976c21f8840e04f4b9ac60931c804fc0debbddf24b710e97804a2b8d357019840534c4fb4b4b816565a49682b0b09b4fb4d82d7d3467af1bb1f
+DIST frameworkintegration-5.55.0.tar.xz 1753068 BLAKE2B 37e61c52427bca163d68ae2d9b6635d83f0287f9f879b91464a54a8b9a3333464ce34b6f2b1f746bd05c144e9034686439d1189741a653ab91140910b43a0510 SHA512 5a16af4c0f763f52fd7c0b46853240bde7c8f95a97864dc746c19f248346754a9a893d2c916ee2d3c8164164994348f53cb3696aaba2d11763f7ba86db2fcab3
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.55.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.55.0.ebuild
new file mode 100644
index 000000000000..abb6426a7b47
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.55.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}