summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcodecs/kcodecs-5.79.0.ebuild')
-rw-r--r--kde-frameworks/kcodecs/kcodecs-5.79.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-frameworks/kcodecs/kcodecs-5.79.0.ebuild b/kde-frameworks/kcodecs/kcodecs-5.79.0.ebuild
new file mode 100644
index 000000000000..151dde78056a
--- /dev/null
+++ b/kde-frameworks/kcodecs/kcodecs-5.79.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for manipulating strings using various encodings"
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/gperf
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}