summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-6.0.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-6.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-6.0.0.ebuild b/kde-frameworks/kdesu/kdesu-6.0.0.ebuild
new file mode 100644
index 000000000000..dc1ef8cc42ab
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-6.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kpty-${PVCUT}*:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}