summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kio/files')
-rw-r--r--kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch46
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-1.patch69
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-2.patch61
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-3.patch52
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-4.patch62
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-fix-filenamesearch-crashes.patch28
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch79
-rw-r--r--kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch105
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch31
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch53
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch76
11 files changed, 0 insertions, 662 deletions
diff --git a/kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch b/kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch
deleted file mode 100644
index 42637cd6e1e7..000000000000
--- a/kde-frameworks/kio/files/kio-5.81.0-fix-qtconcurrent-private-link.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From e6825658b7f59a3a933559def9aebf21ff0efb7f Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 23 Apr 2021 20:10:31 +0200
-Subject: [PATCH] Drop find_dependency(Qt5Concurrent) from
- KF5KIOConfig.cmake.in
-
-This was added in 2f83dde2c8e8a25f0fe3dd52012bb49cb69e1ea5 but as far as I can
-see it is only a KIO build time dependency with no Qt5Concurrent header being
-used in KIO headers.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- KF5KIOConfig.cmake.in | 1 -
- src/core/CMakeLists.txt | 2 +-
- 2 files changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/KF5KIOConfig.cmake.in b/KF5KIOConfig.cmake.in
-index 687ec512..749e9b9b 100644
---- a/KF5KIOConfig.cmake.in
-+++ b/KF5KIOConfig.cmake.in
-@@ -21,7 +21,6 @@ find_dependency(KF5WindowSystem "@KF_DEP_VERSION@")
- endif()
-
- find_dependency(Qt5Network "@REQUIRED_QT_VERSION@")
--find_dependency(Qt5Concurrent "@REQUIRED_QT_VERSION@")
- find_dependency(Qt5DBus "@REQUIRED_QT_VERSION@")
-
- include("${CMAKE_CURRENT_LIST_DIR}/KF5KIOTargets.cmake")
-diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
-index 76c3061c..fe4be56b 100644
---- a/src/core/CMakeLists.txt
-+++ b/src/core/CMakeLists.txt
-@@ -188,9 +188,9 @@ PUBLIC
- KF5::CoreAddons # KJob
- KF5::Service # TODO KF6 move to PRIVATE
- Qt5::Network
-- Qt5::Concurrent # QtConcurrentRun in hostinfo.cpp
- Qt5::DBus
- PRIVATE
-+ Qt5::Concurrent # QtConcurrentRun in hostinfo.cpp
- Qt5::Xml # davjob.cpp uses QDom
- KF5::ConfigCore
- KF5::I18n
---
-2.31.1
-
diff --git a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-1.patch b/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-1.patch
deleted file mode 100644
index 08d72d754d70..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-1.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From e79da836c34fce66231e396c7215314d0eba51b4 Mon Sep 17 00:00:00 2001
-From: Jonathan Marten <jjm@keelhaul.me.uk>
-Date: Sat, 8 May 2021 15:20:39 +0000
-Subject: [PATCH] MimeTypeFinderJob: Resolve symlinks for a local file
-
----
- autotests/mimetypefinderjobtest.cpp | 18 +++++++++++++++++-
- src/core/mimetypefinderjob.cpp | 2 +-
- 2 files changed, 18 insertions(+), 2 deletions(-)
-
-diff --git a/autotests/mimetypefinderjobtest.cpp b/autotests/mimetypefinderjobtest.cpp
-index 72296b9b8..f494ff3b6 100644
---- a/autotests/mimetypefinderjobtest.cpp
-+++ b/autotests/mimetypefinderjobtest.cpp
-@@ -48,6 +48,7 @@ void MimeTypeFinderJobTest::determineMimeType_data()
- QTest::newRow("text_file_no_extension") << "text/plain" << "srcfile";
- QTest::newRow("desktop_file") << "application/x-desktop" << "foo.desktop";
- QTest::newRow("script") << "application/x-shellscript" << "srcfile.sh";
-+ QTest::newRow("directory") << "inode/directory" << "srcdir";
- /* clang-format on */
- }
-
-@@ -60,7 +61,12 @@ void MimeTypeFinderJobTest::determineMimeType()
- QTemporaryDir tempDir;
- const QString srcDir = tempDir.path();
- const QString srcFile = srcDir + QLatin1Char('/') + fileName;
-- createSrcFile(srcFile);
-+ if (mimeType == "inode/directory") {
-+ QVERIFY(QDir(srcDir).mkdir(fileName));
-+ } else {
-+ createSrcFile(srcFile);
-+ }
-+
- QVERIFY(QFile::exists(srcFile));
- const QUrl url = QUrl::fromLocalFile(srcFile);
-
-@@ -68,6 +74,16 @@ void MimeTypeFinderJobTest::determineMimeType()
- KIO::MimeTypeFinderJob *job = new KIO::MimeTypeFinderJob(url, this);
- QVERIFY2(job->exec(), qPrintable(job->errorString()));
- QCOMPARE(job->mimeType(), mimeType);
-+
-+ // Check that the result is the same when accessing the source
-+ // file through a symbolic link (bug #436708)
-+ const QString srcLink = srcDir + QLatin1String("/link_") + fileName;
-+ QVERIFY(QFile::link(srcFile, srcLink));
-+ const QUrl linkUrl = QUrl::fromLocalFile(srcLink);
-+
-+ job = new KIO::MimeTypeFinderJob(linkUrl, this);
-+ QVERIFY2(job->exec(), qPrintable(job->errorString()));
-+ QCOMPARE(job->mimeType(), mimeType);
- }
-
- void MimeTypeFinderJobTest::invalidUrl()
-diff --git a/src/core/mimetypefinderjob.cpp b/src/core/mimetypefinderjob.cpp
-index f5e50cdc4..48fc8c289 100644
---- a/src/core/mimetypefinderjob.cpp
-+++ b/src/core/mimetypefinderjob.cpp
-@@ -122,7 +122,7 @@ void KIO::MimeTypeFinderJobPrivate::statFile()
- {
- Q_ASSERT(m_mimeTypeName.isEmpty());
-
-- KIO::StatJob *job = KIO::statDetails(m_url, KIO::StatJob::SourceSide, KIO::StatBasic, KIO::HideProgressInfo);
-+ KIO::StatJob *job = KIO::statDetails(m_url, KIO::StatJob::SourceSide, KIO::StatBasic | KIO::StatResolveSymlink, KIO::HideProgressInfo);
- if (!m_authPrompts) {
- job->addMetaData(QStringLiteral("no-auth-prompt"), QStringLiteral("true"));
- }
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-2.patch b/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-2.patch
deleted file mode 100644
index bf3ff50802f6..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-2.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From c748d6987252fafc296cde9351b289ef734cf861 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Thu, 13 May 2021 23:03:57 +0200
-Subject: [PATCH] kio_file: pass the absolute path to
- QMimeDatabase::mimeTypeForFile()
-
-Otherwise detecting the mime type based on the file content may fail and
-return application/octet-stream.
-
-And pass the whole url to createUDSEntry(), less QFile::decodeName/encodeName()
-in the middle is better and less error prone.
-
-Note that without this change a MimeTypeFinderJob could end up failing to
-find the mime type of a local file based on the file contents.
----
- src/ioslaves/file/file_unix.cpp | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/ioslaves/file/file_unix.cpp b/src/ioslaves/file/file_unix.cpp
-index 99d46c8f1..940e3cbc4 100644
---- a/src/ioslaves/file/file_unix.cpp
-+++ b/src/ioslaves/file/file_unix.cpp
-@@ -364,7 +364,7 @@ inline static time_t stat_mtime(QT_STATBUF &buf)
- }
- #endif
-
--static bool createUDSEntry(const QString &filename, const QByteArray &path, UDSEntry &entry, KIO::StatDetails details)
-+static bool createUDSEntry(const QString &filename, const QByteArray &path, UDSEntry &entry, KIO::StatDetails details, const QUrl &url)
- {
- assert(entry.count() == 0); // by contract :-)
- int entries = 0;
-@@ -539,7 +539,7 @@ static bool createUDSEntry(const QString &filename, const QByteArray &path, UDSE
-
- if (details & KIO::StatMimeType) {
- QMimeDatabase db;
-- entry.fastInsert(KIO::UDSEntry::UDS_MIME_TYPE, db.mimeTypeForFile(filename).name());
-+ entry.fastInsert(KIO::UDSEntry::UDS_MIME_TYPE, db.mimeTypeForFile(url.toLocalFile()).name());
- }
-
- return true;
-@@ -1186,7 +1186,7 @@ void FileProtocol::listDir(const QUrl &url)
- listEntry(entry);
-
- } else {
-- if (createUDSEntry(filename, QByteArray(ep->d_name), entry, details)) {
-+ if (createUDSEntry(filename, QByteArray(ep->d_name), entry, details, url)) {
- #if HAVE_SYS_XATTR_H
- if (isNtfsHidden(filename)) {
- bool ntfsHidden = true;
-@@ -1476,7 +1476,7 @@ void FileProtocol::stat(const QUrl &url)
- const KIO::StatDetails details = getStatDetails();
-
- UDSEntry entry;
-- if (!createUDSEntry(url.fileName(), _path, entry, details)) {
-+ if (!createUDSEntry(url.fileName(), _path, entry, details, url)) {
- error(KIO::ERR_DOES_NOT_EXIST, path);
- return;
- }
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-3.patch b/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-3.patch
deleted file mode 100644
index a9c55e1f7f24..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-3.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From c19876052ecec18a87a82f5950e8909e22e895ba Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Thu, 13 May 2021 17:02:52 +0200
-Subject: [PATCH] MimeTypeFinderJob: the StatJob details should include the
- mimetype
-
-Apparently we forgot to specify that we want the UDS_MIME_TYPE field in
-the statFile() method (both when it lived in OpenUrlJob and when it was moved
-to MimeTypeFinderJob). And now there is a dedicated StatJob flag, StatMimeType,
-that we can use.
-
-Not passing KIO::StatMimeType when creating the StatJob meant the code always
-used a get job to determine the mime type, which mean that e.g. opening an
-ISO file from Dolphin, which supposedly just needs to launch Ark, had the
-whole file read into memory, which means that opening a couple of ISO's and
-you're out of memory...
-
-Thanks to sitter for doing a big chunk of the investigative work in the bug
-report.
-
-CCBUG: 398908
----
- src/core/mimetypefinderjob.cpp | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/core/mimetypefinderjob.cpp b/src/core/mimetypefinderjob.cpp
-index 48fc8c289..baca58695 100644
---- a/src/core/mimetypefinderjob.cpp
-+++ b/src/core/mimetypefinderjob.cpp
-@@ -122,7 +122,9 @@ void KIO::MimeTypeFinderJobPrivate::statFile()
- {
- Q_ASSERT(m_mimeTypeName.isEmpty());
-
-- KIO::StatJob *job = KIO::statDetails(m_url, KIO::StatJob::SourceSide, KIO::StatBasic | KIO::StatResolveSymlink, KIO::HideProgressInfo);
-+ static constexpr auto statFlags = KIO::StatBasic | KIO::StatResolveSymlink | KIO::StatMimeType;
-+
-+ KIO::StatJob *job = KIO::statDetails(m_url, KIO::StatJob::SourceSide, statFlags, KIO::HideProgressInfo);
- if (!m_authPrompts) {
- job->addMetaData(QStringLiteral("no-auth-prompt"), QStringLiteral("true"));
- }
-@@ -147,6 +149,8 @@ void KIO::MimeTypeFinderJobPrivate::statFile()
-
- const KIO::UDSEntry entry = job->statResult();
-
-+ qCDebug(KIO_CORE) << "UDSEntry from StatJob in MimeTypeFinderJob" << entry;
-+
- const QString localPath = entry.stringValue(KIO::UDSEntry::UDS_LOCAL_PATH);
- if (!localPath.isEmpty()) {
- m_url = QUrl::fromLocalFile(localPath);
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-4.patch b/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-4.patch
deleted file mode 100644
index 9e59a0eb16eb..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-MimeTypeFinderJob-memleak-4.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 71484c97dee0c977a00f141123d8ccd9b93c2e96 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Fri, 14 May 2021 21:19:31 +0200
-Subject: [PATCH] kio_file: fix how createUDSEntry() is called
-
-When calling createUDSEntry() from listDir(), we need to concatenate the full
-path to the item.
-
-This is an addendum to commit c748d6987252f.
----
- src/ioslaves/file/file_unix.cpp | 14 ++++++++++----
- 1 file changed, 10 insertions(+), 4 deletions(-)
-
-diff --git a/src/ioslaves/file/file_unix.cpp b/src/ioslaves/file/file_unix.cpp
-index 940e3cbc4..3573c200e 100644
---- a/src/ioslaves/file/file_unix.cpp
-+++ b/src/ioslaves/file/file_unix.cpp
-@@ -364,7 +364,7 @@ inline static time_t stat_mtime(QT_STATBUF &buf)
- }
- #endif
-
--static bool createUDSEntry(const QString &filename, const QByteArray &path, UDSEntry &entry, KIO::StatDetails details, const QUrl &url)
-+static bool createUDSEntry(const QString &filename, const QByteArray &path, UDSEntry &entry, KIO::StatDetails details, const QString &fullPath)
- {
- assert(entry.count() == 0); // by contract :-)
- int entries = 0;
-@@ -539,7 +539,7 @@ static bool createUDSEntry(const QString &filename, const QByteArray &path, UDSE
-
- if (details & KIO::StatMimeType) {
- QMimeDatabase db;
-- entry.fastInsert(KIO::UDSEntry::UDS_MIME_TYPE, db.mimeTypeForFile(url.toLocalFile()).name());
-+ entry.fastInsert(KIO::UDSEntry::UDS_MIME_TYPE, db.mimeTypeForFile(fullPath).name());
- }
-
- return true;
-@@ -1186,7 +1186,13 @@ void FileProtocol::listDir(const QUrl &url)
- listEntry(entry);
-
- } else {
-- if (createUDSEntry(filename, QByteArray(ep->d_name), entry, details, url)) {
-+ QString fullPath(path);
-+ if (!fullPath.endsWith(QLatin1Char('/'))) {
-+ fullPath += QLatin1Char('/');
-+ }
-+ fullPath += filename;
-+
-+ if (createUDSEntry(filename, QByteArray(ep->d_name), entry, details, fullPath)) {
- #if HAVE_SYS_XATTR_H
- if (isNtfsHidden(filename)) {
- bool ntfsHidden = true;
-@@ -1476,7 +1482,7 @@ void FileProtocol::stat(const QUrl &url)
- const KIO::StatDetails details = getStatDetails();
-
- UDSEntry entry;
-- if (!createUDSEntry(url.fileName(), _path, entry, details, url)) {
-+ if (!createUDSEntry(url.fileName(), _path, entry, details, path)) {
- error(KIO::ERR_DOES_NOT_EXIST, path);
- return;
- }
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.82.0-fix-filenamesearch-crashes.patch b/kde-frameworks/kio/files/kio-5.82.0-fix-filenamesearch-crashes.patch
deleted file mode 100644
index b92139a51871..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-fix-filenamesearch-crashes.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a38fcf356de0cbba1ce97c8ef70979ed897a8094 Mon Sep 17 00:00:00 2001
-From: Kai Uwe Broulik <kde@privat.broulik.de>
-Date: Tue, 18 May 2021 19:54:54 +0200
-Subject: [PATCH] [KCoreDirLister] Guard uiDelegate(), it might be null
-
-BUG: 437153
----
- src/core/kcoredirlister.cpp | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/core/kcoredirlister.cpp b/src/core/kcoredirlister.cpp
-index a836f0aa..58d8791c 100644
---- a/src/core/kcoredirlister.cpp
-+++ b/src/core/kcoredirlister.cpp
-@@ -1288,7 +1288,9 @@ void KCoreDirListerCache::slotResult(KJob *j)
- Q_EMIT kdl->jobError(job);
- if (kdl->d->m_autoErrorHandling && !errorShown) {
- errorShown = true; // do it only once
-- job->uiDelegate()->showErrorMessage();
-+ if (job->uiDelegate()) {
-+ job->uiDelegate()->showErrorMessage();
-+ }
- }
- #if KIOCORE_BUILD_DEPRECATED_SINCE(5, 82)
- kdl->handleError(job);
---
-2.31.1
-
diff --git a/kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch b/kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch
deleted file mode 100644
index 9cc0379b6998..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-no-cache-kcm.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From 581fab08ff4d5539e4684adcffc74ec3517ce29d Mon Sep 17 00:00:00 2001
-From: Nicolas Fella <nicolas.fella@gmx.de>
-Date: Thu, 6 May 2021 21:26:31 +0200
-Subject: [PATCH] Remove the cache KCM
-
-Same reasoning as for
-https://invent.kde.org/frameworks/kio/-/merge_requests/438.
-
-It is very targeted towards KIO-based browsers which don't really exist
-any more.
-
-The setting is also global to everything that uses KIO and it's a bit
-questionable whether for example webdav browsing in Dolphin should
-automatically have the same cache settings as network access in Choqok.
-
-It being part of system settings is also confusing for users since it
-gives the false impression of true globality. They might expect it to
-affect Firefox or Webengine-based Konqueror which it does not.
----
- docs/kcontrol5/CMakeLists.txt | 1 -
- src/kcms/kio/CMakeLists.txt | 4 +-
- src/kcms/kio/main.cpp | 4 +-
- 3 files changed, 2 insertions(+), 7 deletions(-)
-
-diff --git a/docs/kcontrol5/CMakeLists.txt b/docs/kcontrol5/CMakeLists.txt
-index 2dd1ae16a..6c2f21b07 100644
---- a/docs/kcontrol5/CMakeLists.txt
-+++ b/docs/kcontrol5/CMakeLists.txt
-@@ -1,4 +1,3 @@
--add_subdirectory(cache)
- add_subdirectory(cookies)
- add_subdirectory(netpref)
- add_subdirectory(proxy)
-diff --git a/src/kcms/kio/CMakeLists.txt b/src/kcms/kio/CMakeLists.txt
-index 11cd239f2..5281fc7dc 100644
---- a/src/kcms/kio/CMakeLists.txt
-+++ b/src/kcms/kio/CMakeLists.txt
-@@ -12,11 +12,9 @@ set(kcm_kio_PART_SRCS
- smbrodlg.cpp
- kproxydlg.cpp
- netpref.cpp
-- cache.cpp
- ksaveioconfig.cpp)
-
- ki18n_wrap_ui(kcm_kio_PART_SRCS
-- cache.ui
- kproxydlg.ui
- kcookiespolicies.ui
- kcookiesmanagement.ui
-@@ -41,5 +39,5 @@ install(TARGETS kcm_kio DESTINATION ${KDE_INSTALL_PLUGINDIR} )
-
- ########### install files ###############
-
--install( FILES smb.desktop cookies.desktop cache.desktop
-+install( FILES smb.desktop cookies.desktop
- netpref.desktop proxy.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
-diff --git a/src/kcms/kio/main.cpp b/src/kcms/kio/main.cpp
-index 8bacb10ca..2c0ebc29b 100644
---- a/src/kcms/kio/main.cpp
-+++ b/src/kcms/kio/main.cpp
-@@ -13,7 +13,6 @@
- #include <KPluginFactory>
-
- // Local
--#include "cache.h"
- #include "kcookiesmain.h"
- #include "kproxydlg.h"
- #include "netpref.h"
-@@ -21,7 +20,6 @@
-
- K_PLUGIN_FACTORY(KioConfigFactory, registerPlugin<SMBRoOptions>(QStringLiteral("smb")); registerPlugin<KIOPreferences>(QStringLiteral("netpref"));
- registerPlugin<KProxyDialog>(QStringLiteral("proxy"));
-- registerPlugin<KCookiesMain>(QStringLiteral("cookie"));
-- registerPlugin<CacheConfigModule>(QStringLiteral("cache"));)
-+ registerPlugin<KCookiesMain>(QStringLiteral("cookie"));)
-
- #include "main.moc"
---
-GitLab
diff --git a/kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch b/kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch
deleted file mode 100644
index ce0e891e9164..000000000000
--- a/kde-frameworks/kio/files/kio-5.82.0-no-useragent-kcm.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-From 1aa42558a0f539abfe4bc92cf2c8078ac4adb9a0 Mon Sep 17 00:00:00 2001
-From: Nicolas Fella <nicolas.fella@gmx.de>
-Date: Wed, 5 May 2021 22:27:25 +0200
-Subject: [PATCH] Remove the Browser Identification KCM
-
-It's purpose is to control the user agent used by kio-http.
-
-Very few things use kio-http these days, not even Konqueror with the
-webengine part.
-
-For the remaining use cases (kioclient, webdav kio worker, etc.) this
-kind of configurability is overkill.
-
-Moreover being part of systemsettings this gives a false impression of
-globality. A user might change something in there and wonder why it does
-not apply to Firefox or Falkon.
-
-Given the questionable usefulness and the potential for confusion I
-propose to remove it entirely.
----
- docs/kcontrol5/CMakeLists.txt | 1 -
- src/kcms/kio/CMakeLists.txt | 18 +-
- src/kcms/kio/main.cpp | 4 +-
- 3 files changed, 2 insertions(+), 21 deletions(-)
-
-diff --git a/docs/kcontrol5/CMakeLists.txt b/docs/kcontrol5/CMakeLists.txt
-index 1b19e5e7b..2dd1ae16a 100644
---- a/docs/kcontrol5/CMakeLists.txt
-+++ b/docs/kcontrol5/CMakeLists.txt
-@@ -4,5 +4,4 @@ add_subdirectory(netpref)
- add_subdirectory(proxy)
- add_subdirectory(smb)
- add_subdirectory(trash)
--add_subdirectory(useragent)
- add_subdirectory(webshortcuts)
-diff --git a/src/kcms/kio/CMakeLists.txt b/src/kcms/kio/CMakeLists.txt
-index a354651b0..11cd239f2 100644
---- a/src/kcms/kio/CMakeLists.txt
-+++ b/src/kcms/kio/CMakeLists.txt
-@@ -1,6 +1,4 @@
-
--add_subdirectory( uasproviders )
--
- find_package(KF5TextWidgets ${KF_DEP_VERSION} REQUIRED)
-
- ########### next target ###############
-@@ -12,31 +10,18 @@ set(kcm_kio_PART_SRCS
- kcookiesmanagement.cpp
- kcookiespolicyselectiondlg.cpp
- smbrodlg.cpp
-- useragentdlg.cpp
- kproxydlg.cpp
-- useragentinfo.cpp
-- useragentselectordlg.cpp
- netpref.cpp
- cache.cpp
- ksaveioconfig.cpp)
-
- ki18n_wrap_ui(kcm_kio_PART_SRCS
- cache.ui
-- useragentselectordlg.ui
-- useragentdlg.ui
- kproxydlg.ui
- kcookiespolicies.ui
- kcookiesmanagement.ui
- kcookiespolicyselectiondlg.ui)
-
--ecm_qt_export_logging_category(
-- IDENTIFIER KIO_USERAGENTDLG
-- CATEGORY_NAME kf.configwidgets.cms.kf.kio.useragentdlg
-- OLD_CATEGORY_NAMES kf5.kio.useragentdlg
-- DESCRIPTION "kio useragentdialog (KIO)"
-- EXPORT KIO
--)
--
- add_library(kcm_kio MODULE ${kcm_kio_PART_SRCS})
-
- target_link_libraries(kcm_kio
-@@ -56,6 +41,5 @@ install(TARGETS kcm_kio DESTINATION ${KDE_INSTALL_PLUGINDIR} )
-
- ########### install files ###############
-
--install( FILES smb.desktop cookies.desktop useragent.desktop cache.desktop
-+install( FILES smb.desktop cookies.desktop cache.desktop
- netpref.desktop proxy.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
--install( FILES uasprovider.desktop DESTINATION ${KDE_INSTALL_KSERVICETYPES5DIR} )
-diff --git a/src/kcms/kio/main.cpp b/src/kcms/kio/main.cpp
-index f1b065f46..8bacb10ca 100644
---- a/src/kcms/kio/main.cpp
-+++ b/src/kcms/kio/main.cpp
-@@ -18,10 +18,8 @@
- #include "kproxydlg.h"
- #include "netpref.h"
- #include "smbrodlg.h"
--#include "useragentdlg.h"
-
--K_PLUGIN_FACTORY(KioConfigFactory, registerPlugin<UserAgentDlg>(QStringLiteral("useragent")); registerPlugin<SMBRoOptions>(QStringLiteral("smb"));
-- registerPlugin<KIOPreferences>(QStringLiteral("netpref"));
-+K_PLUGIN_FACTORY(KioConfigFactory, registerPlugin<SMBRoOptions>(QStringLiteral("smb")); registerPlugin<KIOPreferences>(QStringLiteral("netpref"));
- registerPlugin<KProxyDialog>(QStringLiteral("proxy"));
- registerPlugin<KCookiesMain>(QStringLiteral("cookie"));
- registerPlugin<CacheConfigModule>(QStringLiteral("cache"));)
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch b/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch
deleted file mode 100644
index 26383b788a01..000000000000
--- a/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 36f1814b184f4d5ac628fca5db5f6cc1440b4db7 Mon Sep 17 00:00:00 2001
-From: Jan Paul Batrina <jpmbatrina01@gmail.com>
-Date: Mon, 12 Jul 2021 22:06:19 +0800
-Subject: [PATCH] Use std::mem_fn instead of the deprecated/removed
- std::mem_fun
-
-std::mem_fun was deprecated in C++11 and removed from
-the standard in C++17.
-
-BUG: 439780
-NO_CHANGELOG
----
- src/widgets/kpropertiesdialog.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/widgets/kpropertiesdialog.cpp b/src/widgets/kpropertiesdialog.cpp
-index 3f61e8ea3..1ed8bc7d8 100644
---- a/src/widgets/kpropertiesdialog.cpp
-+++ b/src/widgets/kpropertiesdialog.cpp
-@@ -2273,7 +2273,7 @@ void KFilePermissionsPropsPlugin::slotShowAdvancedPermissions()
- d->fileSystemSupportsACLs = fileSystemSupportsACL(path);
- }
- if (d->fileSystemSupportsACLs) {
-- std::for_each(theNotSpecials.begin(), theNotSpecials.end(), std::mem_fun(&QWidget::hide));
-+ std::for_each(theNotSpecials.begin(), theNotSpecials.end(), std::mem_fn(&QWidget::hide));
- extendedACLs = new KACLEditWidget(&dlg);
- extendedACLs->setEnabled(d->canChangePermissions);
- vbox->addWidget(extendedACLs);
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch b/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch
deleted file mode 100644
index cdccada57d97..000000000000
--- a/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 8ad6921524c92a0cf1b58336b3ce29e159e83b7d Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Wed, 14 Jul 2021 17:06:59 +0100
-Subject: [PATCH] Fix selecting binaries from component chooser KCM
-
-In the kcmshell for a component chooser we use the open with dialog to
-select services for various scheme handlers.
-
-If you select a binary instead of a .desktop file a temporary .desktop
-file is created in ~/.local/share/applications
-
-This is in the format
-Exec=someBinary
-MimeType=x-scheme-handler/http
-
-When we then use this application for launching KIO::DesktopExecParser
-then (sort of correctly) determines that that the chosen service cannot
-handle the http scheme because even though it is a scheme handler it
-does not have a "%u" in the exec line.
-
-This leads to us potentially loading websites via kioclient or kio-fuse.
-
-Testing done:
- - kcmshell5 component chooser
- - web browser -> other -> type "/usr/bin/firefox"
- - kde-open5 http://kde.org
- - Previously this gave a local URL, now it is correct
----
- src/widgets/kopenwithdialog.cpp | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/src/widgets/kopenwithdialog.cpp b/src/widgets/kopenwithdialog.cpp
-index 1831878ca..31295044d 100644
---- a/src/widgets/kopenwithdialog.cpp
-+++ b/src/widgets/kopenwithdialog.cpp
-@@ -1088,6 +1088,14 @@ bool KOpenWithDialogPrivate::checkAccept()
- KConfigGroup cg = desktopFile.desktopGroup();
- cg.writeEntry("Type", "Application");
- cg.writeEntry("Name", initialServiceName);
-+
-+ // if we select a binary for a scheme handler, then it's safe to assume it can handle URLs
-+ if (qMimeType.startsWith(QLatin1String("x-scheme-handler/"))) {
-+ if (!typedExec.contains(QLatin1String("%u"), Qt::CaseInsensitive) && !typedExec.contains(QLatin1String("%f"), Qt::CaseInsensitive)) {
-+ fullExec += QStringLiteral(" %u");
-+ }
-+ }
-+
- cg.writeEntry("Exec", fullExec);
- cg.writeEntry("NoDisplay", true); // don't make it appear in the K menu
- if (terminal->isChecked()) {
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch b/kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch
deleted file mode 100644
index 033b75bb00b1..000000000000
--- a/kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From fb9bbb6f1fbb4e6232221a851f55ca2dc43b012c Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 23 Apr 2021 20:10:31 +0200
-Subject: [PATCH] Introduce KIO_NO_PUBLIC_QTCONCURRENT option
-
-If set, move Qt5Concurrent to private link interface, drop from
-KF5KIOConfig.cmake.in. Originally added in 2f83dde2, but only used
-in the implementation, not the API.
-
-Test-built various revdeps successfully against the patched KIO
-with/without Qt5Concurrent installed, fixing implicit deps while
-at it. KDE Gear packages fixed in >=21.04.2, Plasma in >=5.21.5.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 3 +++
- KF5KIOConfig.cmake.in | 2 ++
- src/core/CMakeLists.txt | 7 ++++++-
- 3 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e0063c2c..63aef43c 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -49,6 +49,9 @@ option(KIO_ASSERT_SLAVE_STATES
- "Used to control whether slave state assertions are enabled. When not enabled only warnings are generated."
- ${ASSERT_SLAVE_STATES_DEFAULT})
-
-+# TODO KF6: remove
-+option(KIO_NO_PUBLIC_QTCONCURRENT "Privatize QtConcurrent linking, so KIO does not provide the target to revdeps.")
-+
- option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)" OFF)
- add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)")
-
-diff --git a/KF5KIOConfig.cmake.in b/KF5KIOConfig.cmake.in
-index 687ec512..69564b3d 100644
---- a/KF5KIOConfig.cmake.in
-+++ b/KF5KIOConfig.cmake.in
-@@ -21,7 +21,9 @@ find_dependency(KF5WindowSystem "@KF_DEP_VERSION@")
- endif()
-
- find_dependency(Qt5Network "@REQUIRED_QT_VERSION@")
-+if (NOT @KIO_NO_PUBLIC_QTCONCURRENT@)
- find_dependency(Qt5Concurrent "@REQUIRED_QT_VERSION@")
-+endif()
- find_dependency(Qt5DBus "@REQUIRED_QT_VERSION@")
-
- include("${CMAKE_CURRENT_LIST_DIR}/KF5KIOTargets.cmake")
-diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
-index c09d408a..f6efee23 100644
---- a/src/core/CMakeLists.txt
-+++ b/src/core/CMakeLists.txt
-@@ -201,7 +201,6 @@ PUBLIC
- KF5::CoreAddons # KJob
- KF5::Service # TODO KF6 move to PRIVATE
- Qt5::Network
-- Qt5::Concurrent # QtConcurrentRun in hostinfo.cpp # TODO KF6 move to PRIVATE
- Qt5::DBus
- PRIVATE
- Qt5::Xml # davjob.cpp uses QDom
-@@ -211,6 +210,12 @@ PRIVATE
- KF5::DBusAddons # KDEInitInterface
- )
-
-+if(KIO_NO_PUBLIC_QTCONCURRENT)
-+ target_link_libraries(KF5KIOCore PRIVATE Qt5::Concurrent) # QtConcurrentRun in hostinfo.cpp
-+else()
-+ target_link_libraries(KF5KIOCore PUBLIC Qt5::Concurrent) # TODO KF6: remove
-+endif()
-+
- if (UNIX)
- target_link_libraries(KF5KIOCore PRIVATE KF5::AuthCore) #SlaveBase uses KAuth::Action
- endif()
---
-2.32.0
-