summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/knotifications/knotifications-6.1.0.ebuild')
-rw-r--r--kde-frameworks/knotifications/knotifications-6.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/knotifications-6.1.0.ebuild b/kde-frameworks/knotifications/knotifications-6.1.0.ebuild
new file mode 100644
index 000000000000..0711aa0a9817
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-6.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for notifying the user of an event"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ media-libs/libcanberra
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"