summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/ktexteditor')
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.57.0-shortcuts.patch54
-rw-r--r--kde-frameworks/ktexteditor/ktexteditor-5.57.0-r1.ebuild58
2 files changed, 112 insertions, 0 deletions
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.57.0-shortcuts.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.57.0-shortcuts.patch
new file mode 100644
index 000000000000..2f979d681227
--- /dev/null
+++ b/kde-frameworks/ktexteditor/files/ktexteditor-5.57.0-shortcuts.patch
@@ -0,0 +1,54 @@
+From 9f2ffd36c5873f4d2645f07129ead7970871808c Mon Sep 17 00:00:00 2001
+From: Christoph Cullmann <cullmann@kde.org>
+Date: Sun, 14 Apr 2019 14:38:31 +0200
+Subject: avoid conflicting shortcuts for switching tabs
+
+Summary: use ALT + Home/End for top/bottom of view
+
+Subscribers: kwrite-devel, kde-frameworks-devel
+
+Tags: #kate, #frameworks
+
+Differential Revision: https://phabricator.kde.org/D20534
+---
+ src/view/kateview.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/view/kateview.cpp b/src/view/kateview.cpp
+index 7220d26..55457c7 100644
+--- a/src/view/kateview.cpp
++++ b/src/view/kateview.cpp
+@@ -1046,13 +1046,13 @@ void KTextEditor::ViewPrivate::setupEditActions()
+
+ a = ac->addAction(QStringLiteral("move_top_of_view"));
+ a->setText(i18n("Move to Top of View"));
+- ac->setDefaultShortcut(a, QKeySequence(Qt::CTRL + Qt::Key_PageUp));
++ ac->setDefaultShortcut(a, QKeySequence(Qt::ALT + Qt::Key_Home));
+ connect(a, SIGNAL(triggered(bool)), SLOT(topOfView()));
+ m_editActions << a;
+
+ a = ac->addAction(QStringLiteral("select_top_of_view"));
+ a->setText(i18n("Select to Top of View"));
+- ac->setDefaultShortcut(a, QKeySequence(Qt::CTRL + Qt::SHIFT + Qt::Key_PageUp));
++ ac->setDefaultShortcut(a, QKeySequence(Qt::ALT + Qt::SHIFT + Qt::Key_Home));
+ connect(a, SIGNAL(triggered(bool)), SLOT(shiftTopOfView()));
+ m_editActions << a;
+
+@@ -1070,13 +1070,13 @@ void KTextEditor::ViewPrivate::setupEditActions()
+
+ a = ac->addAction(QStringLiteral("move_bottom_of_view"));
+ a->setText(i18n("Move to Bottom of View"));
+- ac->setDefaultShortcut(a, QKeySequence(Qt::CTRL + Qt::Key_PageDown));
++ ac->setDefaultShortcut(a, QKeySequence(Qt::ALT + Qt::Key_End));
+ connect(a, SIGNAL(triggered(bool)), SLOT(bottomOfView()));
+ m_editActions << a;
+
+ a = ac->addAction(QStringLiteral("select_bottom_of_view"));
+ a->setText(i18n("Select to Bottom of View"));
+- ac->setDefaultShortcut(a, QKeySequence(Qt::CTRL + Qt::SHIFT + Qt::Key_PageDown));
++ ac->setDefaultShortcut(a, QKeySequence(Qt::ALT + Qt::SHIFT + Qt::Key_End));
+ connect(a, SIGNAL(triggered(bool)), SLOT(shiftBottomOfView()));
+ m_editActions << a;
+
+--
+cgit v1.1
diff --git a/kde-frameworks/ktexteditor/ktexteditor-5.57.0-r1.ebuild b/kde-frameworks/ktexteditor/ktexteditor-5.57.0-r1.ebuild
new file mode 100644
index 000000000000..550a3354398f
--- /dev/null
+++ b/kde-frameworks/ktexteditor/ktexteditor-5.57.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing a full text editor component"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="editorconfig git"
+
+BDEPEND="
+ test? ( $(add_frameworks_dep kservice) )
+"
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ editorconfig? ( app-text/editorconfig-core-c )
+ git? ( dev-libs/libgit2:= )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-shortcuts.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package editorconfig EditorConfig)
+ $(cmake-utils_use_find_package git LibGit2)
+ )
+
+ kde5_src_configure
+}