summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/prison')
-rw-r--r--kde-frameworks/prison/Manifest1
-rw-r--r--kde-frameworks/prison/prison-5.53.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/prison/Manifest b/kde-frameworks/prison/Manifest
index 98d9af9dfb0f..a54b6eac9b8c 100644
--- a/kde-frameworks/prison/Manifest
+++ b/kde-frameworks/prison/Manifest
@@ -1 +1,2 @@
DIST prison-5.52.0.tar.xz 41756 BLAKE2B d2aedf3cbe591d435218836b191579b6df00ece15e5f4526e13128e63531f83cb43ffc21248ee2b06d4e169525d77bee5031a073094a49f5843d94b626203186 SHA512 5592e99865d491fef36aa10552245f555aaf12a9bc0b17e2df44efb091ac1d06fb1ada647c63c33a1df32737f34943202db6a286b714a1bfb63fa0180a433797
+DIST prison-5.53.0.tar.xz 41744 BLAKE2B 1c0d88b38471d00b9d7fdc2ee3cc74cb9c18756ce757c847f2590ba338ef77a949c19d57aeab7ff0a5463255d3d61b953cad8275f47989571c53c3e54109f592 SHA512 405d23f8e4c036d731f1d5d5878592e369816c2163a11f7f367ddd34ec511047e9d2e13b0315928cd816d354332d96b450d3b1e15a80bdc485f54b872daa49bf
diff --git a/kde-frameworks/prison/prison-5.53.0.ebuild b/kde-frameworks/prison/prison-5.53.0.ebuild
new file mode 100644
index 000000000000..da7a539ce3cb
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.53.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ $(add_qt_dep qtgui)
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( $(add_qt_dep qtdeclarative) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package qml Qt5Quick)
+ )
+
+ kde5_src_configure
+}