summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/qqc2-desktop-style')
-rw-r--r--kde-frameworks/qqc2-desktop-style/Manifest4
-rw-r--r--kde-frameworks/qqc2-desktop-style/metadata.xml10
-rw-r--r--kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.116.1.ebuild (renamed from kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.82.0.ebuild)13
-rw-r--r--kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.84.0.ebuild28
-rw-r--r--kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-6.2.0.ebuild31
5 files changed, 50 insertions, 36 deletions
diff --git a/kde-frameworks/qqc2-desktop-style/Manifest b/kde-frameworks/qqc2-desktop-style/Manifest
index c305d2927b49..9cf9b2f2f562 100644
--- a/kde-frameworks/qqc2-desktop-style/Manifest
+++ b/kde-frameworks/qqc2-desktop-style/Manifest
@@ -1,2 +1,2 @@
-DIST qqc2-desktop-style-5.82.0.tar.xz 60076 BLAKE2B 1d743ff60c5862740bd2ef9c0dcadacca3f63f239a78dbd12e459f929f323b695ddd9c03323146b7ac34772ff76f2137e8dad826e04abef6a1f4ed514163e305 SHA512 ce4db38f835971d6f63dced360db8a320e06e3a6f808bd017d56548041f6d0332b119dc0f6d4e160c7847d9d47e6818d2a867e0f243e58fd6c56843643d55a52
-DIST qqc2-desktop-style-5.84.0.tar.xz 59960 BLAKE2B 6787aae84a9fd6657801ae2b90dedc8736f98b6b3fc0a769c6f269dc29f7e46dbe2f826c6a38725d3c25d3c9fb405221d1c1179e706e3efe4101d9bcebcb4bd8 SHA512 9cb24d5013dea87fe96c4de464e8c72934e578385fe371880b6e599e46b45631c677f8b98c367bc60252cfadff2142da0652010d734c4f57d7ac46599bcb029a
+DIST qqc2-desktop-style-5.116.1.tar.xz 73068 BLAKE2B 713b863a08785f8d8a3509aad938818881e71bc2b966d10d823a805733bf2a5382337b7966a5c11c005ddf99a5e9ef377d59658568fc8cdcbdd1c35be41e1b09 SHA512 80520c19717f9150b6b0e91f45e65ef967f7fbadaff5b1f6bdab526822706a361e0094ded93826ea9fb2dc3028f8cd076e03b2067dbfc1d43ff764bc5ae5facb
+DIST qqc2-desktop-style-6.2.0.tar.xz 84360 BLAKE2B 59e12dd871b73fa75049a9c88885ffa64765962787acd5ee8d444c4f42d47b9feaaa39aa0c4a484b1f2197103f09422879a66852a7f6c0d800bb584c1003d0a1 SHA512 c63d7c043a2f28b53268e98583cc6772b9efeb7636f6d5ddff09333c4f2f0e170d8a4fc9205eac4ecf3d4fe54800abf3ad011634b97bd3f30eb53da730fa9239
diff --git a/kde-frameworks/qqc2-desktop-style/metadata.xml b/kde-frameworks/qqc2-desktop-style/metadata.xml
index 2fdbf33d963d..506ecf605bc4 100644
--- a/kde-frameworks/qqc2-desktop-style/metadata.xml
+++ b/kde-frameworks/qqc2-desktop-style/metadata.xml
@@ -1,8 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Frameworks API.
+ </subslots>
+ </slots>
</pkgmetadata>
diff --git a/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.82.0.ebuild b/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.116.1.ebuild
index 0d1060b73b9c..e6b354dbd922 100644
--- a/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.82.0.ebuild
+++ b/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.116.1.ebuild
@@ -1,26 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_QTHELP="false"
PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.2
-inherit ecm kde.org
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
DESCRIPTION="Style for QtQuickControls 2 that uses QWidget's QStyle for painting"
LICENSE="|| ( GPL-2+ LGPL-3+ )"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
IUSE=""
DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5=
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
=kde-frameworks/kconfigwidgets-${PVCUT}*:5
=kde-frameworks/kiconthemes-${PVCUT}*:5
=kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/sonnet-${PVCUT}*:5[qml]
"
RDEPEND="${DEPEND}
>=dev-qt/qtgraphicaleffects-${QTMIN}:5
diff --git a/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.84.0.ebuild b/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.84.0.ebuild
deleted file mode 100644
index ac284e1bcdf5..000000000000
--- a/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-5.84.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_QTHELP="false"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.2
-inherit ecm kde.org
-
-DESCRIPTION="Style for QtQuickControls 2 that uses QWidget's QStyle for painting"
-
-LICENSE="|| ( GPL-2+ LGPL-3+ )"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5=
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kirigami-${PVCUT}*:5
-"
-RDEPEND="${DEPEND}
- >=dev-qt/qtgraphicaleffects-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
-"
diff --git a/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-6.2.0.ebuild b/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-6.2.0.ebuild
new file mode 100644
index 000000000000..f16eae109fb7
--- /dev/null
+++ b/kde-frameworks/qqc2-desktop-style/qqc2-desktop-style-6.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Style for QtQuickControls 2 that uses QWidget's QStyle for painting"
+
+LICENSE="|| ( GPL-2+ LGPL-3+ )"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Qt_6_PRIVATE_API matches org.kde.desktop.so, see also:
+# https://invent.kde.org/frameworks/qqc2-desktop-style/-/merge_requests/379
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6=
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/sonnet-${PVCUT}*:6[qml]
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qt5compat-${QTMIN}:6
+"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"