summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.75.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 529e07c441a7..1c80cf8485eb 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.74.0.tar.xz 293316 BLAKE2B 55f73f617b98c85a4f63abea6eb327ee2f017ee2d63f3c739269afb5311e392b153d8c6a7f29dc9be095450c48d7a220cc387d6d842175a345044c084bc868bb SHA512 80f19d6f7c168f6daed208769c5abe1c664b48cd5d8f3ddd75f3992f917859d14281ed12b819b5bc9f501849243de639388a8e47dc60e0d3bda0e5b8426a54e6
+DIST sonnet-5.75.0.tar.xz 293896 BLAKE2B 95a6532cc3c68f97b1bf4c97196320f73c46bc35ed0b422add51d6b75de7629c18405d7f841b88fd69c1af44fe2de623a24ed1f60297e2039dbe89d9f03e9432 SHA512 8ce91c819142f7546d37ffccbcce13a56109ec23767f2af14713a84102b04889ea0bfd4bd3d3b332df8946e0a161d2af8b8f11799afa893dfd9fc2839e013142
diff --git a/kde-frameworks/sonnet/sonnet-5.75.0.ebuild b/kde-frameworks/sonnet/sonnet-5.75.0.ebuild
new file mode 100644
index 000000000000..f5798c21f8c1
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.75.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}