summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kdesu/Manifest1
-rw-r--r--kde-frameworks/kdesu/kdesu-5.109.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/Manifest b/kde-frameworks/kdesu/Manifest
index 236bd07d007e..68d53134a07c 100644
--- a/kde-frameworks/kdesu/Manifest
+++ b/kde-frameworks/kdesu/Manifest
@@ -1 +1,2 @@
DIST kdesu-5.108.0.tar.xz 56548 BLAKE2B 51589131fd6f710cac30ef56c0ebd7d064d4d94075831a401faac05cf9a2d4e29d5034c0330bb5405399e6a3e88156384c802d21ea7e36f0aec0edf6f0973c46 SHA512 329a34b281f67cf0b0ac69ed833cb30b7b3405458be5fccc892b1b023a7f80e0976d2b68cbdb6a9a7cb428414d575b9a1f48c8388eab226607c6130a32556aae
+DIST kdesu-5.109.0.tar.xz 56800 BLAKE2B 02dea82c5c87d938b6dda8103147175ff43d6b7d3d4a5da0288c156bdf08d0493d41569c7c6ea463ea26c85545b0973de05e82dcf5417eaafdec45b11b426943 SHA512 70991dae4a194d7f2a810f062bce8c2178256399f9e2d02c9c561adff8047b67e26124c1260383bc0b3df52d076c72b372179c57fd1db93d58614fd3691f67a6
diff --git a/kde-frameworks/kdesu/kdesu-5.109.0.ebuild b/kde-frameworks/kdesu/kdesu-5.109.0.ebuild
new file mode 100644
index 000000000000..5a865e54023e
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.109.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to handle super user actions"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv"
+IUSE="X"
+
+RDEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kpty-${PVCUT}*:5
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}