summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-locate/kio-locate-0.5.3-r2.ebuild')
-rw-r--r--kde-misc/kio-locate/kio-locate-0.5.3-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-misc/kio-locate/kio-locate-0.5.3-r2.ebuild b/kde-misc/kio-locate/kio-locate-0.5.3-r2.ebuild
new file mode 100644
index 000000000000..dcfec179e885
--- /dev/null
+++ b/kde-misc/kio-locate/kio-locate-0.5.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional" # not optional until !kdelibs4support
+inherit kde5
+
+DESCRIPTION="Locate KIO slave"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/kio-locate?content=120965"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1460972255/120965-${P}.tar.gz"
+# See also: https://github.com/reporter123/kio-locate/commits/master
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+ "${FILESDIR}/${P}-kf5port.patch"
+)
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ sys-apps/mlocate
+"