summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.5.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 903aa3d67fd7..cd9f9ccba09d 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.4.3.tar.xz 19476 SHA256 7eb6025e58e8cd57cab640ab42ff9670ae113317534001be94916610135127a3 SHA512 b8378263806014c225a3c7337c1fcf0a513cf508db718e6154304f49841e0d3744b61a58058093e021f4ace8b282842bb7d90ae5a9ad912af222cbaedaac0aad WHIRLPOOL ed0c6a399bc4338b1b17ea2c790f1f9490eb1f2de01aa3b1aa5dcb8a7c919f5b4895e0eea65c76b624d2071436f1a0c60cc1256d0a320a60b8dccd4ea1af1031
DIST ksshaskpass-5.5.4.tar.xz 20568 SHA256 42c2e64191ec0e42019b99fb1170ad5b368b59077aa6e3ea8e7a6293d0718f42 SHA512 39c8892400499c1711c6cc00aca9eaf761aa03f7d642e4e4b81f32ec1e20a9ee059b3d292b94ad8a772bab594f69ba5db532327da0d870a1d65582b8c4e3bcf8 WHIRLPOOL 709e49e2207ac8501312e14d2c969f29e36681d9d0f7e8c2091e1c6dbd4ba0d14a2373f184bb90db97ac34ddc46ba0275a9e0842f1c1e6df7e423e2e28b56d77
+DIST ksshaskpass-5.5.5.tar.xz 20556 SHA256 8a5c48f50c4449e39dc312ca5d3dc8cec466d2fc6ad4602adf0d41ee3828fc6b SHA512 48018fe6c42e15c5338cba280f05215c6b3e0e9f015641b377f8ab0c00e6e2898e5fb9e463ac044485268378c0f0a6d6d43c4829881fbd9825c4e4dbe0dc8c1a WHIRLPOOL 5fedc473d93f5ffe66c06daff739a096306ba05e3f86c122529514a6786987d950b397f47f988a431cdb67bce2fb61a472f979bb8a7118164056ba561724148a
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.5.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.5.5.ebuild
new file mode 100644
index 000000000000..ed1fdbac0d72
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.5.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/ksshaskpass
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}