summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwayland-server/kwayland-server-5.24.4-r1.ebuild')
-rw-r--r--kde-plasma/kwayland-server/kwayland-server-5.24.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-server/kwayland-server-5.24.4-r1.ebuild b/kde-plasma/kwayland-server/kwayland-server-5.24.4-r1.ebuild
new file mode 100644
index 000000000000..033b2c03dc1c
--- /dev/null
+++ b/kde-plasma/kwayland-server/kwayland-server-5.24.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Wayland Server Components built on KDE Frameworks"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-server"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/wayland-1.19.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+ >=dev-libs/wayland-protocols-1.24
+"
+BDEPEND="
+ || (
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ <dev-qt/qtwayland-5.15.3:5
+ )
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-layer-shell-reset.patch
+ "${FILESDIR}"/${P}-guard-subsurface-parent-access.patch # bug 452044
+ "${FILESDIR}"/${P}-fix-crash-on-screen-setup-change.patch # bug 452318
+)