summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.91.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 61ef18f2e0bb..50f8e4287e0f 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.27.10.tar.xz 89832 BLAKE2B 9279a29ae28d2ff8cbce6e6c9675300fba37c91b59f60c535d4f32ca54b222b2438a7e01747b864681d257cbeaf48248f4397c9d1dcd4142d4da5321fa3216a7 SHA512 a69b65cbf5cbabdb53359adb067ed673bf5582c1768aba7a6f5377f17369f95e9646e23bbac3efa0d67e12cc3705e6411e4d1a1fea1da9243937965573d12f4b
DIST plasma-integration-5.27.9.tar.xz 89796 BLAKE2B 081c36fe46bf60b50a7691bd87c40ba1c85fd5fa7adc1918da6ea0d4327ed51f29771525acd33bc2688c10fab5c766a5edc81af528fedb4a35b760ee1d0f5dea SHA512 d1f028962eb421896a6db885e126b8fd2b21f61c84018404c428f0fd9beb78e37af45ee4099ac11f4ce0df199de7820e3f6683a7e1c34e1a6d79c55a8d9a3625
+DIST plasma-integration-5.91.0.tar.xz 91732 BLAKE2B 5e8345f98593538cdb9758dce464563376926cd51f58a1d200a42b436bf1a79aaed669cea5cba06ef38a24c6a77390baa617254ef9916140ea9c3e66e3eadf25 SHA512 984573e7353a1d66f6791143d0b054fc282ecc1709ce4bc67d1368d38d86583b2e4b34e3eb99621f25c65363d0a3afe2fb365a8754a215b7ed8e44f83d8bb4ea
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.91.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.91.0.ebuild
new file mode 100644
index 000000000000..5b21991b74e7
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.91.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KF5MIN=5.106.0
+KFMIN=5.247.0
+PVCUT=$(ver_cut 1-3)
+QT5MIN=5.15.9
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="qt5"
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libXcursor
+ x11-libs/libxcb
+ qt5? (
+ >=dev-qt/qtdbus-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QT5MIN}:5
+ >=dev-qt/qtwayland-${QT5MIN}:5
+ >=dev-qt/qtwidgets-${QT5MIN}:5
+ >=dev-qt/qtx11extras-${QT5MIN}:5
+ >=kde-frameworks/kcompletion-${KF5MIN}:5
+ >=kde-frameworks/kconfig-${KF5MIN}:5
+ >=kde-frameworks/kconfigwidgets-${KF5MIN}:5
+ >=kde-frameworks/kcoreaddons-${KF5MIN}:5
+ >=kde-frameworks/kguiaddons-${KF5MIN}:5
+ >=kde-frameworks/ki18n-${KF5MIN}:5
+ >=kde-frameworks/kiconthemes-${KF5MIN}:5
+ >=kde-frameworks/kio-${KF5MIN}:5
+ >=kde-frameworks/kjobwidgets-${KF5MIN}:5
+ >=kde-frameworks/knotifications-${KF5MIN}:5
+ >=kde-frameworks/kwindowsystem-${KF5MIN}:5
+ >=kde-frameworks/kxmlgui-${KF5MIN}:5
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.11.1
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+ media-fonts/noto-emoji
+"
+PDEPEND="
+ >=kde-plasma/xdg-desktop-portal-kde-${PVCUT}:6
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ qt5? ( >=dev-qt/qtwaylandscanner-${QT5MIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT6=ON
+ -DBUILD_QT5=$(usex qt5)
+ )
+ ecm_src_configure
+}