summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.7.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 3273e28475b7..4f74cf7fb1ba 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.6.5.tar.xz 52552 SHA256 40e8716f3472d1a2b22bc44d51d76901c8ce0606e7587b549584cb7e9e1c87e8 SHA512 a8952f25ed2eacc96c7957c4f2d21397fe5a75a9dcfacca67e3b7111095be380128c4663276bba838cb30e877f02ded184867e29ad591fd62caed63114a79eed WHIRLPOOL 2af37abc93c7534642a93726c60fa5cd6e4095b65d8a7c0e192864c9529a04962ef84cf5ab0961711b6dc39bdd93a71367181ee2a2f415e8ba8d3614470e70d1
DIST plasma-integration-5.7.0.tar.xz 48500 SHA256 311612b858a53e738db24f0b70cb4cd5e6e1da59c50d481d5e518232cc051566 SHA512 fd5ee9b0950953deb37c58f974d88022448517d5847b7722c472cb1afda87d9e09dc2bff40e41a443b49bc087e1b76ffa295e8d0c2efaba8b583457b5c6866a7 WHIRLPOOL 71ec05fec409c6a4e2301e07f2472765a8c8eef2cfbb8d166f0318c6db2650f7131533f1d8424604e746521bc173bb21fd745b6b9170316cdaa8a9dd9b67024e
+DIST plasma-integration-5.7.1.tar.xz 48960 SHA256 86156e170569a816158ac812be9faedd99f9b347371179d427f90f5fb4579289 SHA512 9e16ec63c61ec4b3ae2acfa679d27bec1eeb611878db9f230802d8c9f92b3c80caabe32c353dd8225242901e92f342812d3d773371785b136dbc291e44aa2bfe WHIRLPOOL 1bdc09186891763c6815c81e63cc37e41632880e2b748689bf61d7772be237e7d7832e1ce42d1159a2166d8e848dc9fe7586be158eca78f040d387a9eabbf012
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.7.1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.7.1.ebuild
new file mode 100644
index 000000000000..d6c4ad63e6ff
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep oxygen-fonts '' 5.4.3)
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT="test"