summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-thunderbolt')
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest1
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index 16b1fc65a483..1f87baa34876 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1,3 +1,4 @@
DIST plasma-thunderbolt-5.27.10.tar.xz 72112 BLAKE2B b527f7225fe6f85b2168406b4d049813ed3da9616b577f3d9606151d391bbb1237ed2a84e49f3b3dbdc601d52f54a8f25f91d5980ee812518cff105b602656c4 SHA512 5a93e390332ab14f212ef60c1fe8b0af16256058ab70d7504699b8109c4b28a02dfe7597665168f6dc9061397fa08c670897c0f5cc9cb64576cc979052d924d8
DIST plasma-thunderbolt-5.27.11.tar.xz 72824 BLAKE2B c6c7fb62b255388672116a0e0cd9d36637a8ace2e2b559e39ebb5a64867c1c3057f832875885990fec3cd0a478bb177f8e10f5cb05c486e33b097836f7f3dd4a SHA512 8ba96ca33d32b3185e7026c75f8b6158df4cee88e4f2a5e42a1a86faf22391fe62112e441cc1d41a36e7a7b74cef3d61ac2426399e0e71a862d88807c404c6f8
DIST plasma-thunderbolt-6.0.1.tar.xz 75408 BLAKE2B d099ea9dfa0ad0908387a753928e4c43ee0554f8f228872154520f4dc9841f15e2c942228a5053cf126a31896bd0e6d0c4506c4b33a0107e29622bb5a76e49ec SHA512 27cd0bfeaa829c4ad23b66178079a8c568fc6048fa54a3a712b2c5570acf2d078dcaeee70b7048aae51560d03a779e443ee98ca8c0e1c58c26bdfa7315e0a70d
+DIST plasma-thunderbolt-6.0.2.tar.xz 75448 BLAKE2B d906cf1ac09ff1656d698c947f50e593cddaff2291d1e17c5fbd763f388b7c742a8736c8d7f20c45299098d664629fe333873abd95b3c4b09f9dd6e04eb28953 SHA512 d8ed80653411649b3da0d0c92cceb22a27989e03dd403481420ab6d61fb84bc6dcea7dc73f2065afd85f6cc38f5ff69cc0a1748d48d57b879add3ab69bf2d541
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild
new file mode 100644
index 000000000000..88642424e300
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ sys-apps/bolt
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"