summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-thunderbolt')
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest1
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.91.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index c733f09be6bc..f7e3b4366250 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1,2 +1,3 @@
DIST plasma-thunderbolt-5.27.10.tar.xz 72112 BLAKE2B b527f7225fe6f85b2168406b4d049813ed3da9616b577f3d9606151d391bbb1237ed2a84e49f3b3dbdc601d52f54a8f25f91d5980ee812518cff105b602656c4 SHA512 5a93e390332ab14f212ef60c1fe8b0af16256058ab70d7504699b8109c4b28a02dfe7597665168f6dc9061397fa08c670897c0f5cc9cb64576cc979052d924d8
DIST plasma-thunderbolt-5.27.9.tar.xz 72108 BLAKE2B d699f4a97a128aa6ebd25249f9f21b228e8f5ab52a67dad467e12702444c537abefcdff9c0c3c3bd3f58067468bd998b2c8b3f0b9f5907db9d9ed73254c95166 SHA512 3ab445eb660f9b882186ec8267f6dc678f703ad1ebf3bb063759eb29092f9f650bcfc0a2feac3724c877b03be5439ea818f48ded0af272f15606526683155dd3
+DIST plasma-thunderbolt-5.91.0.tar.xz 74552 BLAKE2B 2e74e7e03ce0f4dd0ac18708b0fa1f064240fdb7643d52c3cad85906b1a8f15411343e49ecc52aaefcd2e62a81e2a5386c8c52b27c660fc9fba987a6e62ca62d SHA512 256d41b9f941012580637b351b08222a3f25d46c9ec5f7899d0982d05aabbfc5f3f945a6db8fe60abaebb8cc9f7d0c9618dfcc94fbb77fd3d51100d5c0ac33ba
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.91.0.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.91.0.ebuild
new file mode 100644
index 000000000000..ce5a3b1d03d6
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.91.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.247.0
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ sys-apps/bolt
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"