summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-thunderbolt')
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest1
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.93.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index 64c6769578e4..3c11fac26175 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1,2 +1,3 @@
DIST plasma-thunderbolt-5.27.10.tar.xz 72112 BLAKE2B b527f7225fe6f85b2168406b4d049813ed3da9616b577f3d9606151d391bbb1237ed2a84e49f3b3dbdc601d52f54a8f25f91d5980ee812518cff105b602656c4 SHA512 5a93e390332ab14f212ef60c1fe8b0af16256058ab70d7504699b8109c4b28a02dfe7597665168f6dc9061397fa08c670897c0f5cc9cb64576cc979052d924d8
DIST plasma-thunderbolt-5.92.0.tar.xz 74568 BLAKE2B 97cadcc6b707ef65982eff561e6193b1de8e4984bbe5e10dfacbfbf1528fda513fca4e4f385bbbfe03e481d45e3cdc13ff285449d20fee5ded43e61b323d9dd5 SHA512 cb9e69fbb876eb7a28ebfad36456ae28a92fdd62708ec3d5d1baa8aaadd3825ebbed732bc5146c31c492bd9e63869efd9ab8637d9faa0a1fae629726c27191c7
+DIST plasma-thunderbolt-5.93.0.tar.xz 74440 BLAKE2B f85792c87e3afdad97ee8d03bc122270c02c69b23823d139a73d277a84777ad6dfc620fdf9a15ea6dfdeff516f383f69c95ca86878142a8366ab7a7c898a2c91 SHA512 f6b0dbb87ce15f2725e6df2fa5f6a21c3b004e4c101d30a816845206937595ca5b8cbd2329a8ec911467c804f4e218e49824abba1a591de864585517b14d0c52
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.93.0.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.93.0.ebuild
new file mode 100644
index 000000000000..14b1a4da3d2b
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.93.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.249.0
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ sys-apps/bolt
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"