summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest1
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.27.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index 1976ed42e121..8ba5b96c34d1 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1 +1,2 @@
DIST plasma-thunderbolt-5.27.4.tar.xz 71824 BLAKE2B dc61ad8af0e978cb90a37b51dc591c40aa1408c40d7a0dc74cfc57ae749f4e46fcdc8477f9161255feb9c4e31c37e0a0008603833567d6ff1c1582f4e0c47e39 SHA512 e2860cebc8efbf2556b99a9abc0e2e5f03deff71f2378dfd56fc4d8235c4aec30307e94f89521bf6d2ac86b6249cc3f74931c0cb37ed424f0d3add131eafaae4
+DIST plasma-thunderbolt-5.27.5.tar.xz 71980 BLAKE2B 8907b3b73eb6b6b507991e73097b882c9fabea16f9dca6c271bcb01de7923eb106f3fce2a044d661417e3387d2ac17637b7e7651dc2b124a1c520cf9646aa1f5 SHA512 b2550c7014561048bd16498689dcc7309d7abf3e6e403fad7629404f30fd8bd31f7ef3841309a06bae50c8d09deeeee64b12b0d1af5ff1b98e158eb216950f44
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.27.5.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.27.5.ebuild
new file mode 100644
index 000000000000..19770a5e9f05
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.27.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ sys-apps/bolt
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"