summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/liblxqt/liblxqt-1.0.0.ebuild')
-rw-r--r--lxqt-base/liblxqt/liblxqt-1.0.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-1.0.0.ebuild b/lxqt-base/liblxqt/liblxqt-1.0.0.ebuild
deleted file mode 100644
index 30baaaa8e5d2..000000000000
--- a/lxqt-base/liblxqt/liblxqt-1.0.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Common base library for the LXQt desktop environment"
-HOMEPAGE="https://lxqt-project.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-fi
-
-LICENSE="LGPL-2.1+ BSD"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="+backlight"
-
-BDEPEND="
- dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.10.0
-"
-DEPEND="
- >=dev-libs/libqtxdg-3.8.0
- >=dev-qt/qtcore-5.15:5
- >=dev-qt/qtdbus-5.15:5
- >=dev-qt/qtgui-5.15:5
- >=dev-qt/qtwidgets-5.15:5
- >=dev-qt/qtx11extras-5.15:5
- >=dev-qt/qtxml-5.15:5
- kde-frameworks/kwindowsystem:5[X]
- x11-libs/libX11
- x11-libs/libXScrnSaver
- backlight? ( sys-auth/polkit-qt )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_BACKLIGHT_LINUX_BACKEND=$(usex backlight)
- )
- cmake_src_configure
-}