summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-policykit/lxqt-policykit-1.2.0.ebuild')
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-1.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-1.2.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-1.2.0.ebuild
new file mode 100644
index 000000000000..2315addb9e42
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.12.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}