summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/hap')
-rw-r--r--mail-client/hap/Manifest1
-rw-r--r--mail-client/hap/files/hap-3.7-ncurses.patch14
-rw-r--r--mail-client/hap/hap-3.7-r1.ebuild39
-rw-r--r--mail-client/hap/metadata.xml5
4 files changed, 59 insertions, 0 deletions
diff --git a/mail-client/hap/Manifest b/mail-client/hap/Manifest
new file mode 100644
index 000000000000..fbde181a46ac
--- /dev/null
+++ b/mail-client/hap/Manifest
@@ -0,0 +1 @@
+DIST hap-3.7.tar 194560 SHA256 ae2aa6fbc2d95bcdc0a58cb8e51e458eff868241bd6576123bc291a55d8c4de2 SHA512 3a42b8ae5d4c96812190e0551df289ad748c11f93d7632de1698437246723fd159a3f1a0b6f06c925b31ce8e389b73bc0b3a68f978570ae5d9f283d1651fa42b WHIRLPOOL a250c94dde3af898f4df81eef458735a08daf0c33c914abea4fb521c0088164078224322768256cb7ec58e7e7288094ec3770651394dc05dd376aa95de6ce918
diff --git a/mail-client/hap/files/hap-3.7-ncurses.patch b/mail-client/hap/files/hap-3.7-ncurses.patch
new file mode 100644
index 000000000000..1ae79b9e9810
--- /dev/null
+++ b/mail-client/hap/files/hap-3.7-ncurses.patch
@@ -0,0 +1,14 @@
+--- configure.in 1996-07-17 00:50:03.000000000 +0300
++++ configure.in 2013-03-06 15:09:29.579148360 +0200
+@@ -6,8 +6,9 @@
+ AC_PROG_INSTALL
+
+ dnl Checks for libraries.
+-dnl Replace `main' with a function in -ltermcap:
+-AC_CHECK_LIB(termcap, tputs)
++dnl Replace `main' with a function in -lncurses or -ltinfo
++AC_CHECK_LIB(ncurses, tputs,,
++ [AC_CHECK_LIB(tinfo, tputs)])
+
+ dnl Checks for header files.
+ AC_CHECK_HEADERS(sgtty.h unistd.h libc.h termcap.h strings.h string.h dirent.h sys/ioctl.h)
diff --git a/mail-client/hap/hap-3.7-r1.ebuild b/mail-client/hap/hap-3.7-r1.ebuild
new file mode 100644
index 000000000000..76f2c0417d4e
--- /dev/null
+++ b/mail-client/hap/hap-3.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A terminal mail notification program (replacement for biff)"
+HOMEPAGE="http://www.transbay.net/~enf/sw.html"
+SRC_URI="http://www.transbay.net/~enf/${P}.tar"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Fix configure to use ncurses instead of termcap (bug #103105)
+ epatch "${FILESDIR}/${P}-ncurses.patch"
+
+ # Fix Makefile.in to use our CFLAGS and LDFLAGS
+ sed -i -e "s/^CFLAGS=-O/CFLAGS=${CFLAGS}/" \
+ -e "s/^LDFLAGS=.*/LDFLAGS=${LDFLAGS}/" Makefile.in || die
+
+ # Rebuild the compilation framework
+ eautoreconf
+}
+
+src_install() {
+ dobin hap
+ doman hap.1
+ dodoc README HISTORY
+}
diff --git a/mail-client/hap/metadata.xml b/mail-client/hap/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/mail-client/hap/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>