summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/thunderbird/thunderbird-102.4.0.ebuild')
-rw-r--r--mail-client/thunderbird/thunderbird-102.4.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/mail-client/thunderbird/thunderbird-102.4.0.ebuild b/mail-client/thunderbird/thunderbird-102.4.0.ebuild
index 1ff0425c8ce4..50477ea0ed9b 100644
--- a/mail-client/thunderbird/thunderbird-102.4.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.4.0.ebuild
@@ -200,8 +200,8 @@ llvm_check_deps() {
fi
if use clang ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- einfo "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
+ einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
@@ -567,10 +567,12 @@ src_configure() {
einfo "Current RUSTFLAGS:\t\t${RUSTFLAGS:-no value set}"
local have_switched_compiler=
- if use clang && ! tc-is-clang ; then
+ if use clang; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
- have_switched_compiler=yes
+ if tc-is-gcc; then
+ have_switched_compiler=yes
+ fi
AR=llvm-ar
AS=llvm-as
CC=${CHOST}-clang