summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt-wizard/Manifest1
-rw-r--r--mail-client/mutt-wizard/metadata.xml18
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-0_pre20200606.ebuild48
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-9999.ebuild48
4 files changed, 115 insertions, 0 deletions
diff --git a/mail-client/mutt-wizard/Manifest b/mail-client/mutt-wizard/Manifest
new file mode 100644
index 000000000000..2fe037de0813
--- /dev/null
+++ b/mail-client/mutt-wizard/Manifest
@@ -0,0 +1 @@
+DIST mutt-wizard-0_pre20200606.tar.gz 32391 BLAKE2B 2ea165c8a94ebb7a7e28ff466c93f87a0a9f89de98ad71039ea610b6120c1c89922a39ee505159e4139d9a6d29b727ae706a2ec57378b838774a7564afe54e74 SHA512 008688a7d7ad8d895334900a0a060a7c3724519a4a49120d50e9cb0b1cad6e3c63fd7f16985333e35fb46b1bdaae3934750fbc52370dc36927f9bc8482fb5363
diff --git a/mail-client/mutt-wizard/metadata.xml b/mail-client/mutt-wizard/metadata.xml
new file mode 100644
index 000000000000..9dcfae8270a4
--- /dev/null
+++ b/mail-client/mutt-wizard/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ A system for automatically configuring neomutt and isync with a simple
+ interface and safe passwords. Support for multiple domains and automatic
+ offline email sync. Integrable with a lot of other utilities for additional
+ functionality for managing emails.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/mail-client/mutt-wizard/mutt-wizard-0_pre20200606.ebuild b/mail-client/mutt-wizard/mutt-wizard-0_pre20200606.ebuild
new file mode 100644
index 000000000000..9eaf38595153
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-0_pre20200606.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ COMMIT=9ec2a49af03cf542c7db82bc0dd0ccdde81922d4
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}
diff --git a/mail-client/mutt-wizard/mutt-wizard-9999.ebuild b/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
new file mode 100644
index 000000000000..9eaf38595153
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ COMMIT=9ec2a49af03cf542c7db82bc0dd0ccdde81922d4
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}