summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/policyd-weight')
-rw-r--r--mail-filter/policyd-weight/Manifest1
-rw-r--r--mail-filter/policyd-weight/files/policyd-weight.init.d-r129
-rw-r--r--mail-filter/policyd-weight/metadata.xml15
-rw-r--r--mail-filter/policyd-weight/policyd-weight-0.1.15.2-r1.ebuild43
4 files changed, 88 insertions, 0 deletions
diff --git a/mail-filter/policyd-weight/Manifest b/mail-filter/policyd-weight/Manifest
new file mode 100644
index 000000000000..81a735fd8859
--- /dev/null
+++ b/mail-filter/policyd-weight/Manifest
@@ -0,0 +1 @@
+DIST policyd-weight-0.1.15.2.tar.gz 75347 SHA256 7aee2b5b71a89dd774d8dfff761e0ddc7910b38dbe42f895ca21e8af7a30bb42 SHA512 37702762c171b208d37651b2051b521e4f44708b7bb7e0d3001fd2ba123b227c847bad8dd479d7a56f9aeab02fdfd957d34b2c4d7f3a9fd727614cd4031f8b78 WHIRLPOOL 0f606e509ef2f1b8c4b049e5fe45a7c52ebaac64af5b6928b6e1f0fc4e8ff520f724d871124590147993c20315c6d43e4c210abae3e67986fa15134666a3a404
diff --git a/mail-filter/policyd-weight/files/policyd-weight.init.d-r1 b/mail-filter/policyd-weight/files/policyd-weight.init.d-r1
new file mode 100644
index 000000000000..ffcc17a82b08
--- /dev/null
+++ b/mail-filter/policyd-weight/files/policyd-weight.init.d-r1
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+
+extra_started_commands="reload"
+
+daemon="policyd-weight"
+exec="/usr/libexec/postfix/policyd-weight"
+
+depend(){
+ before postfix
+ use net
+}
+
+start(){
+ ebegin "Starting ${daemon}"
+ ${exec} start
+ eend $?
+}
+
+stop(){
+ ebegin "Stopping ${daemon}"
+ ${exec} -k stop
+ eend $?
+}
+
+reload(){
+ ebegin "Reloading ${daemon}"
+ ${exec} reload
+ eend $?
+}
diff --git a/mail-filter/policyd-weight/metadata.xml b/mail-filter/policyd-weight/metadata.xml
new file mode 100644
index 000000000000..84785fb4e4f3
--- /dev/null
+++ b/mail-filter/policyd-weight/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription lang="en">
+ policyd-weight is a Perl policy daemon for the Postfix MTA (2.1 and
+ later) intended to eliminate forged envelope senders and HELOs (i.e. in
+ bogus mails). It allows you to score DNSBLs (RBL/RHSBL), HELO, MAIL
+ FROM and client IP addresses before any queuing is done. It allows you
+ to REJECT messages which have a score higher than allowed, providing
+ improved blocking of spam and virus mails. policyd-weight caches the
+ most frequent client/sender combinations (SPAM as well as HAM) to reduce
+ the number of DNS queries.
+ </longdescription>
+</pkgmetadata>
diff --git a/mail-filter/policyd-weight/policyd-weight-0.1.15.2-r1.ebuild b/mail-filter/policyd-weight/policyd-weight-0.1.15.2-r1.ebuild
new file mode 100644
index 000000000000..8fbf7a7f0392
--- /dev/null
+++ b/mail-filter/policyd-weight/policyd-weight-0.1.15.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils user
+
+DESCRIPTION="Weighted Policy daemon for Postfix"
+HOMEPAGE="http://www.policyd-weight.org/"
+SRC_URI="http://www.policyd-weight.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/perl-Sys-Syslog
+ dev-perl/Net-DNS
+ >=mail-mta/postfix-2.1"
+
+pkg_setup() {
+ enewgroup 'polw'
+ enewuser 'polw' -1 -1 -1 'polw'
+}
+
+src_compile() { :; }
+
+src_install() {
+ exeinto /usr/libexec/postfix
+ doexe policyd-weight
+ fowners root:wheel /usr/libexec/postfix/policyd-weight
+
+ doman man/man5/*.5 man/man8/*.8
+ dodoc *.txt
+
+ sed -i -e "s:^ \$LOCKPATH.*: \$LOCKPATH = '/var/run/policyd-weight/'; # must be a directory (add:" policyd-weight.conf.sample || die
+ insinto /etc
+ newins policyd-weight.conf.sample policyd-weight.conf
+
+ newinitd "${FILESDIR}/${PN}.init.d-r1" "${PN}"
+}