summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/files/4.0.0-tests-strip2.t.patch20
-rw-r--r--mail-filter/spamassassin/spamassassin-4.0.0.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/mail-filter/spamassassin/files/4.0.0-tests-strip2.t.patch b/mail-filter/spamassassin/files/4.0.0-tests-strip2.t.patch
new file mode 100644
index 000000000000..94e1059259b5
--- /dev/null
+++ b/mail-filter/spamassassin/files/4.0.0-tests-strip2.t.patch
@@ -0,0 +1,20 @@
+https://bz.apache.org/SpamAssassin/show_bug.cgi?id=8096
+--- a/t/strip2.t
++++ b/t/strip2.t
+@@ -4,14 +4,15 @@
+ use SATest; sa_t_init("strip2");
+
+ use Test::More;
++use constant HAS_TEXTDIFF => eval { require Text::Diff; };
+ plan skip_all => 'Long running tests disabled' unless conf_bool('run_long_tests');
++plan skip_all => 'Need Text::Diff' unless HAS_TEXTDIFF;
+ plan tests => 98;
+
+ # ---------------------------------------------------------------------------
+
+ use File::Copy;
+ use File::Compare qw(compare_text);
+-use Text::Diff;
+
+ my @files = qw(
+ data/nice/crlf-endings
diff --git a/mail-filter/spamassassin/spamassassin-4.0.0.ebuild b/mail-filter/spamassassin/spamassassin-4.0.0.ebuild
index 5670fd623a56..1799185e12fa 100644
--- a/mail-filter/spamassassin/spamassassin-4.0.0.ebuild
+++ b/mail-filter/spamassassin/spamassassin-4.0.0.ebuild
@@ -91,6 +91,7 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/spamassassin.apache.
PATCHES=(
"${FILESDIR}/mention-geoip.cf-in-init.pre.patch"
"${FILESDIR}/4.0.0-tests-dnsbl_subtests.t.patch"
+ "${FILESDIR}/4.0.0-tests-strip2.t.patch"
)
# There are a few renames and use-dependent ones in src_install as well.