summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base/mate-common/mate-common-1.24.0.ebuild')
-rw-r--r--mate-base/mate-common/mate-common-1.24.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/mate-base/mate-common/mate-common-1.24.0.ebuild b/mate-base/mate-common/mate-common-1.24.0.ebuild
new file mode 100644
index 000000000000..f62fd085c893
--- /dev/null
+++ b/mate-base/mate-common/mate-common-1.24.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate-desktop.org
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Common files for development of MATE packages"
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+}
+
+src_install() {
+ mv doc-build/README README.doc-build \
+ || die "Failed to rename doc-build/README."
+
+ default
+
+ dodoc doc/usage.txt
+}