summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base/mate-menus')
-rw-r--r--mate-base/mate-menus/Manifest1
-rw-r--r--mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/mate-base/mate-menus/Manifest b/mate-base/mate-menus/Manifest
index 0169283dbf80..cbf7fb1e57e4 100644
--- a/mate-base/mate-menus/Manifest
+++ b/mate-base/mate-menus/Manifest
@@ -1 +1,2 @@
DIST mate-menus-1.10.1.tar.xz 342516 SHA256 bd46d676bd4780f815d8343f8a8c3e67645c85fb812a943a0a69e664d3dcddbc SHA512 f0a96334c71052060d2f40b309b91a0a6464f8bd8135e43b29b3e9c67332b01205ffe1a3e2b262b910bbd0a679acd4ebd67b6de604c1e5cfb2bc42bf54028a86 WHIRLPOOL ae24e8bb2b99966e7676f535f6c9d0bfd32223d0dd9e9c5a371c40b15ce9b788cf9b0a7af7df1a2f5880b2fa03aa12fe45e43caaaba48450164c8bc23e47aa4a
+DIST mate-menus-1.12.0.tar.xz 342488 SHA256 b0b735be91cca632d7c63f254a9442201608b24f1d5588a1ff05b50da41b95c4 SHA512 12788d5b88c1dba7b561a3119e311a9724629d1f9ae7d54a9e4443946b331c532310c79b7b39bcacc791697ac52d4b55338051da66c4d747c371575a03183ba6 WHIRLPOOL ec1137ea30f36537dda4aa6d6432f6712a644fa942b618f83a069c8dcdf357b3106e2db6aea86a3dce19f66c053b4fb6e780143e4eab0f42e4eb246bdda29981
diff --git a/mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild b/mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..d3d3db1388c7
--- /dev/null
+++ b/mate-base/mate-menus/mate-menus-1.12.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="debug +introspection python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.36.0:2
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ python? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ mate_src_prepare
+ use python && python_copy_sources
+}
+
+src_configure() {
+ # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
+ # usage checks.
+ mate_py_cond_func_wrap mate_src_configure \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_enable python) \
+ $(use_enable introspection)
+}
+
+src_compile() {
+ mate_py_cond_func_wrap default
+}
+
+src_test() {
+ mate_py_cond_func_wrap emake check
+}
+
+src_install() {
+ mate_py_cond_func_wrap mate_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/10-xdg-menu-mate"
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+ einfo "Due to upstream bug"
+ einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
+ einfo "it is highly recommended to run the following command"
+ einfo "once you have logged in to your desktop for the first time:"
+ einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
+}