summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/source-serif/source-serif-4.005.ebuild')
-rw-r--r--media-fonts/source-serif/source-serif-4.005.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-fonts/source-serif/source-serif-4.005.ebuild b/media-fonts/source-serif/source-serif-4.005.ebuild
new file mode 100644
index 000000000000..596bb8c2182a
--- /dev/null
+++ b/media-fonts/source-serif/source-serif-4.005.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJORV="${PV%%.*}"
+FONT_PN=${PN}-${MAJORV}
+
+inherit font optfeature
+
+DESCRIPTION="Serif font family for user interface environments"
+HOMEPAGE="https://adobe-fonts.github.io/source-serif/"
+SRC_URI="https://github.com/adobe-fonts/source-serif/archive/${PV}R.tar.gz -> source-serif-${PV}.tar.gz"
+S="${WORKDIR}/${P}R"
+
+LICENSE="OFL-1.1"
+SLOT="${MAJORV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RESTRICT="binchecks strip"
+
+RDEPEND="media-libs/fontconfig"
+
+FONT_CONF=( "${FILESDIR}"/63-${FONT_PN}.conf )
+FONT_SUFFIX="otf"
+
+src_prepare() {
+ default
+ mv OTF/*.otf . || die
+}
+
+pkg_postinst() {
+ optfeature_header "Other variants of this font are:"
+ optfeature "the monospace variant" media-fonts/source-code-pro
+ optfeature "Chinese, Japanese and Korean support" media-fonts/source-han-sans
+ optfeature "the sans-serif variant" media-fonts/source-sans
+}