summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild')
-rw-r--r--media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild b/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild
new file mode 100644
index 000000000000..bd64d259240f
--- /dev/null
+++ b/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+GIT_COMMIT="ad4fc3c04b9e25212d78c231e1507458dfea8909"
+
+DESCRIPTION="Automatic color correction and resizing of photos"
+HOMEPAGE="https://web.archive.org/web/20220728233436/http://log69.com/aaphoto_en.html https://github.com/log69/aaphoto"
+SRC_URI="https://github.com/log69/${PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}