summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/autopano-sift-C')
-rw-r--r--media-gfx/autopano-sift-C/autopano-sift-C-2.5.1-r1.ebuild32
-rw-r--r--media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild28
-rw-r--r--media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch24
-rw-r--r--media-gfx/autopano-sift-C/metadata.xml2
4 files changed, 57 insertions, 29 deletions
diff --git a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1-r1.ebuild b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..e7fa26e0d0f3
--- /dev/null
+++ b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="SIFT algorithm for automatic panorama creation in C"
+HOMEPAGE="https://hugin.sourceforge.net/ http://user.cs.tu-berlin.de/~nowozin/autopano-sift/"
+SRC_URI="https://downloads.sourceforge.net/hugin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libxml2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpano13:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}
+ !media-gfx/autopano-sift
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-lm.patch
+ "${FILESDIR}"/${P}-include-order.patch # bug 759514
+)
diff --git a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
deleted file mode 100644
index b9fffc443b2a..000000000000
--- a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="SIFT algorithm for automatic panorama creation in C"
-HOMEPAGE="http://hugin.sourceforge.net/ http://user.cs.tu-berlin.de/~nowozin/autopano-sift/"
-SRC_URI="mirror://sourceforge/hugin/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE=""
-
-DEPEND="
- dev-libs/libxml2
- media-libs/libpano13:0=
- media-libs/libpng:0=
- media-libs/tiff:0=
- sys-libs/zlib
- virtual/jpeg:0"
-RDEPEND="${DEPEND}
- !media-gfx/autopano-sift
-"
-
-PATCHES=( "${FILESDIR}"/${P}-lm.patch )
diff --git a/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch
new file mode 100644
index 000000000000..becab6d4aeb1
--- /dev/null
+++ b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch
@@ -0,0 +1,24 @@
+Subject: [PATCH] adjust to include order deoendency
+
+---
+ autopano-sift-C-2.5.1/KeypointXML.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/autopano-sift-C-2.5.1/KeypointXML.c b/autopano-sift-C-2.5.1/KeypointXML.c
+index 9da70a8..30c35e1 100644
+--- a/KeypointXML.c
++++ b/KeypointXML.c
+@@ -13,10 +13,9 @@
+ * (C) Copyright 2004 -- Sebastian Nowozin (nowozin@cs.tu-berlin.de)
+ */
+
+-#include "AutoPanoSift.h"
+-
+ #include <libxml/xmlreader.h>
+ #include <libxml/xmlwriter.h>
++#include "AutoPanoSift.h"
+
+ KeypointXMLList* KeypointXMLReader_ReadComplete (char* filename)
+ {
+--
+2.26.2
diff --git a/media-gfx/autopano-sift-C/metadata.xml b/media-gfx/autopano-sift-C/metadata.xml
index f602a555b7e2..657d527727bc 100644
--- a/media-gfx/autopano-sift-C/metadata.xml
+++ b/media-gfx/autopano-sift-C/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>