summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/chafa')
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.6.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index 7cedc3a6ba41..9b46610ff308 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
DIST chafa-1.6.0.tar.xz 417888 BLAKE2B f9837a9062396f92974088ea2e59e050089b462442ac01af17dc7f47f4c3a24542facd4c977cac2ee9db3c4af9bae2349cea9186f9d0362cf7bb74f4e83d345b SHA512 47843b8bf1b0555ae3570f688229e9f848e2e30c80aa277278230196f6fdb583b7f9170d1740171f2f4c5d5d915e00df407722067bcf6f2dc888804b7bd074da
+DIST chafa-1.6.1.tar.xz 418720 BLAKE2B 5f6c42311d81bf508f5ec890d72508fd2255e226102b8a7c5c71a9bc1293cd75b08c6b640ca4e6fe9ae34ad47e4e408e25a1aeed7057a5bd823550bea4526f4a SHA512 96cf772638e1a6874d94636a69d6c76d1040d956a16be851ea818292f5b2252867acd0891fede3e030de591b5567d820cf062c5a103a0943a0ea2f2ba34eea77
diff --git a/media-gfx/chafa/chafa-1.6.1.ebuild b/media-gfx/chafa/chafa-1.6.1.ebuild
new file mode 100644
index 000000000000..0949da594e0d
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}