summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/comical')
-rw-r--r--media-gfx/comical/Manifest1
-rw-r--r--media-gfx/comical/comical-0.8-r3.ebuild53
-rw-r--r--media-gfx/comical/files/comical-0.8-syslibs.patch91
-rw-r--r--media-gfx/comical/files/comical-0.8-wxGTK-2.8.patch12
-rw-r--r--media-gfx/comical/files/comical.desktop9
-rw-r--r--media-gfx/comical/metadata.xml8
6 files changed, 174 insertions, 0 deletions
diff --git a/media-gfx/comical/Manifest b/media-gfx/comical/Manifest
new file mode 100644
index 000000000000..4a773066af31
--- /dev/null
+++ b/media-gfx/comical/Manifest
@@ -0,0 +1 @@
+DIST comical-0.8.tar.gz 480270 SHA256 0b6527cc06b25a937041f1eb248d0fd881cf055362097036b939817f785ab85e
diff --git a/media-gfx/comical/comical-0.8-r3.ebuild b/media-gfx/comical/comical-0.8-r3.ebuild
new file mode 100644
index 000000000000..df2d14d13caa
--- /dev/null
+++ b/media-gfx/comical/comical-0.8-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils gnome2-utils toolchain-funcs wxwidgets
+
+DESCRIPTION="A sequential image display program, to deal with .cbr and .cbz files"
+HOMEPAGE="http://comical.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-arch/unrar-4.1.4-r2
+ sys-libs/zlib[minizip]
+ x11-libs/wxGTK:2.8[X]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ export WX_GTK_VER=2.8
+ need-wxwidgets unicode
+
+ epatch \
+ "${FILESDIR}"/${P}-wxGTK-2.8.patch \
+ "${FILESDIR}"/${P}-syslibs.patch
+
+ sed -i -e "s:wx-config:${WX_CONFIG}:" {.,src}/Makefile || die
+
+ rm -rf un{rar,zip}
+}
+
+src_compile() {
+ tc-export CXX
+ emake -j1
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc AUTHORS ChangeLog README TODO
+
+ doicon 'Comical Icons'/${PN}.xpm
+ doicon -s 128 'Comical Icons'/${PN}.png
+
+ domenu "${FILESDIR}"/${PN}.desktop
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/media-gfx/comical/files/comical-0.8-syslibs.patch b/media-gfx/comical/files/comical-0.8-syslibs.patch
new file mode 100644
index 000000000000..e831bc82c4a7
--- /dev/null
+++ b/media-gfx/comical/files/comical-0.8-syslibs.patch
@@ -0,0 +1,91 @@
+Use system libminizip (zlib) wrt http://bugs.gentoo.org/407269.
+Use system libunrar. Use CXX and CXXFLAGS instead of CC and CFLAGS for g++.
+Stop using passing libraries from LDFLAGS and use LDLIBS instead.
+
+--- Makefile
++++ Makefile
+@@ -1,5 +1,5 @@
+-CC = `wx-config --cxx`
+-LDFLAGS = `wx-config --libs` -Lunrar -lunrar -Lunzip -lminiunzip
++CXX ?= `wx-config --cxx`
++LDLIBS = `wx-config --libs` -lunrar `pkg-config --libs minizip`
+ INSTALL = install
+ INSTALL_PROGRAM = $(INSTALL)
+ prefix = /usr/local
+@@ -12,18 +12,12 @@
+
+ all: comical
+
+-comical: $(OBJS) unrar/libunrar.a unzip/libminiunzip.a
+- $(CC) -o $@ $(OBJS) $(LDFLAGS)
++comical: $(OBJS)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(OBJS) $(LDLIBS)
+
+ $(OBJS):
+ $(MAKE) -C src
+
+-unrar/libunrar.a:
+- $(MAKE) lib -C unrar -f makefile.linux
+-
+-unzip/libminiunzip.a:
+- $(MAKE) -C unzip
+-
+ install: comical
+ $(INSTALL_PROGRAM) comical $(DESTDIR)$(bindir)/comical
+
+@@ -39,8 +33,6 @@
+
+ distclean:
+ $(MAKE) clean
+- $(MAKE) clean -C unrar -f makefile.linux
+- $(MAKE) clean -C unzip
+ rm -f $(DEPS) bin2h src/bin2h.o
+
+ .PHONY : install install-strip uninstall clean distclean
+--- src/ComicBookRAR.h
++++ src/ComicBookRAR.h
+@@ -29,7 +29,7 @@
+ #define _ComicBookRAR_h_
+
+ #include "ComicBook.h"
+-#include "dll.hpp"
++#include <dll.hpp>
+
+ class ComicBookRAR : public ComicBook {
+
+--- src/ComicBookZIP.cpp
++++ src/ComicBookZIP.cpp
+@@ -27,7 +27,7 @@
+
+ #include "ComicBookZIP.h"
+ #include <wx/mstream.h>
+-#include "unzip.h"
++#include <unzip.h>
+ #include "Exceptions.h"
+ #include <cstring>
+ #include <errno.h>
+--- src/Makefile
++++ src/Makefile
+@@ -1,6 +1,5 @@
+-INCLUDE = -I../unrar -I../unzip
+-CFLAGS = -O2 -Wall -pipe
+-CPPFLAGS = `wx-config --cxxflags` $(CFLAGS) -D_UNIX $(INCLUDE)
++CXXFLAGS += -Wall `wx-config --cxxflags` `pkg-config --cflags minizip` -I/usr/include/libunrar
++CPPFLAGS += -D_UNIX $(CXXFLAGS)
+
+ .SUFFIXES: .cpp .png .h .d .o
+
+@@ -21,11 +20,11 @@
+ @echo -e "};\n\n#endif" >> $@
+
+ %.o : %.cpp
+- $(CC) $(CPPFLAGS) -c -o $*.o $<
++ $(CXX) $(CPPFLAGS) -c -o $*.o $<
+
+ %.d : %.cpp
+ @set -e; rm -f $@; \
+- $(CC) -MM -MG $(CPPFLAGS) -MT '$*.o' $< > $@.$$$$; \
++ $(CXX) -MM -MG $(CPPFLAGS) -MT '$*.o' $< > $@.$$$$; \
+ sed 's,\($*\)\.o[ :]*,\1.o $@ : ,g' < $@.$$$$ > $@; \
+ rm -f $@.$$$$
+
diff --git a/media-gfx/comical/files/comical-0.8-wxGTK-2.8.patch b/media-gfx/comical/files/comical-0.8-wxGTK-2.8.patch
new file mode 100644
index 000000000000..007aab3e3738
--- /dev/null
+++ b/media-gfx/comical/files/comical-0.8-wxGTK-2.8.patch
@@ -0,0 +1,12 @@
+http://comical.svn.sourceforge.net/viewvc/comical/trunk/src/ComicalApp.cpp?r1=170&r2=171
+
+--- src/ComicalApp.cpp
++++ src/ComicalApp.cpp
+@@ -28,6 +28,7 @@
+ #include "ComicalApp.h"
+ #include "ComicalFrame.h"
+ #include <wx/log.h>
++#include <wx/icon.h>
+
+ #if !defined(__WXMAC__) && !defined(__WXCOCOA__) && !defined(__WXMSW__) && !defined(__WXPM__)
+ #include "../Comical Icons/comical.xpm"
diff --git a/media-gfx/comical/files/comical.desktop b/media-gfx/comical/files/comical.desktop
new file mode 100644
index 000000000000..14a3a08e8202
--- /dev/null
+++ b/media-gfx/comical/files/comical.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Comical
+GenericName=Comic Book Reader
+Exec=comical %F
+Icon=comical
+Type=Application
+Terminal=false
+Categories=Graphics;Viewer;
+MimeType=application/x-cbr;application/x-cbz;
diff --git a/media-gfx/comical/metadata.xml b/media-gfx/comical/metadata.xml
new file mode 100644
index 000000000000..20cf5ef857a0
--- /dev/null
+++ b/media-gfx/comical/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">comical</remote-id>
+ </upstream>
+</pkgmetadata>