summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/digikam/files')
-rw-r--r--media-gfx/digikam/files/digikam-7.10.0-gcc13.patch25
-rw-r--r--media-gfx/digikam/files/digikam-7.8.0-cmake.patch119
-rw-r--r--media-gfx/digikam/files/digikam-7.9.0-akonadi-23.04.patch27
3 files changed, 0 insertions, 171 deletions
diff --git a/media-gfx/digikam/files/digikam-7.10.0-gcc13.patch b/media-gfx/digikam/files/digikam-7.10.0-gcc13.patch
deleted file mode 100644
index 98e78df74d8c..000000000000
--- a/media-gfx/digikam/files/digikam-7.10.0-gcc13.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9c4fed4b5562c777fc6639ead9bcc95faacdb992 Mon Sep 17 00:00:00 2001
-From: Maik Qualmann <metzpinguin@gmail.com>
-Date: Sun, 26 Mar 2023 13:19:40 +0200
-Subject: [PATCH] fix compile DNG-SDK with GCC13
-
----
- core/libs/dngwriter/extra/dng_sdk/dng_string.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/core/libs/dngwriter/extra/dng_sdk/dng_string.cpp b/core/libs/dngwriter/extra/dng_sdk/dng_string.cpp
-index 4e76fc4c86a..7814aff145d 100644
---- a/core/libs/dngwriter/extra/dng_sdk/dng_string.cpp
-+++ b/core/libs/dngwriter/extra/dng_sdk/dng_string.cpp
-@@ -27,7 +27,7 @@
- # endif
- #endif
-
--#if qiPhone || qAndroid
-+#if qLinux || qiPhone || qAndroid
- #include <ctype.h> // for isdigit
- #endif
-
---
-GitLab
-
diff --git a/media-gfx/digikam/files/digikam-7.8.0-cmake.patch b/media-gfx/digikam/files/digikam-7.8.0-cmake.patch
deleted file mode 100644
index d698626e8c7e..000000000000
--- a/media-gfx/digikam/files/digikam-7.8.0-cmake.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-From 618e3f3ba195a3b50812d1184ebf90555d659055 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 17 Feb 2019 23:51:03 +0100
-Subject: [PATCH] Un-break optional Qt5/KF5 detection
-
-And if we enable an option, make the necessary libraries REQUIRED.
----
- core/CMakeLists.txt | 50 +++++++++++++--------------------------------
- 1 file changed, 14 insertions(+), 36 deletions(-)
-
-diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
-index de599ee881..8aef35e062 100644
---- a/core/CMakeLists.txt
-+++ b/core/CMakeLists.txt
-@@ -65,17 +65,14 @@ find_package(Qt5 ${QT_MIN_VERSION} REQUIRED
- )
-
- if(ENABLE_QWEBENGINE)
-- find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS WebEngineWidgets)
-+ find_package(Qt5WebEngineWidgets ${QT_MIN_VERSION} REQUIRED NO_MODULE)
- else()
-- find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS WebKitWidgets)
-+ find_package(Qt5WebKitWidgets ${QT_MIN_VERSION} REQUIRED NO_MODULE)
- endif()
-
--find_package(Qt5 ${QT_MIN_VERSION}
-- OPTIONAL_COMPONENTS
-- DBus
-- OpenGL
-- XmlPatterns # For Rajce plugin
--)
-+find_package(Qt5DBus ${QT_MIN_VERSION})
-+find_package(Qt5OpenGL ${QT_MIN_VERSION})
-+find_package(Qt5XmlPatterns ${QT_MIN_VERSION}) # For Rajce plugin
-
- if(ENABLE_DBUS)
- if(NOT Qt5DBus_FOUND)
-@@ -86,16 +83,11 @@ endif()
- # Dependencies For unit tests and CLI test tools
-
- if(BUILD_TESTING)
-- find_package(Qt5 ${QT_MIN_VERSION} REQUIRED
-- NO_MODULE COMPONENTS
-- Test
-- )
-+ find_package(Qt5Test ${QT_MIN_VERSION} NO_MODULE)
-
-- find_package(Qt5 ${QT_MIN_VERSION}
-- QUIET
-- OPTIONAL_COMPONENTS
-- Qml WebView # Optional, for 'sialis' O2 library test tool.
-- )
-+ # Optional, for 'sialis' O2 library test tool.
-+ find_package(Qt5Qml ${QT_MIN_VERSION} QUIET NO_MODULE)
-+ find_package(Qt5WebView ${QT_MIN_VERSION} QUIET NO_MODULE)
- endif()
-
- find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
-@@ -121,7 +113,7 @@ find_package(KF5 ${KF5_MIN_VERSION} QUIET
- if(ENABLE_KFILEMETADATASUPPORT)
-
- find_package(KF5 ${KF5_MIN_VERSION}
-- QUIET
-+ REQUIRED
- OPTIONAL_COMPONENTS
- FileMetaData # For Plasma destop file indexer support.
- )
-@@ -130,7 +122,7 @@ endif()
-
- if(ENABLE_AKONADICONTACTSUPPORT)
-
-- find_package(KF5 ${AKONADI_MIN_VERSION} QUIET
-+ find_package(KF5 ${AKONADI_MIN_VERSION} REQUIRED
- OPTIONAL_COMPONENTS
- AkonadiContact # For KDE Mail Contacts support.
- Contacts # API for contacts/address book data.
-@@ -138,28 +130,14 @@ if(ENABLE_AKONADICONTACTSUPPORT)
-
- endif()
-
--find_package(KF5 ${KSANE_MIN_VERSION} QUIET
-- OPTIONAL_COMPONENTS
-- Sane # For digital scanner support.
--)
-+find_package(KF5Sane ${KSANE_MIN_VERSION} QUIET) # For digital scanner support.
-
--find_package(KF5 ${CALENDAR_MIN_VERSION} QUIET
-- OPTIONAL_COMPONENTS
-- CalendarCore # For Calendar tool.
--)
-+find_package(KF5CalendarCore ${CALENDAR_MIN_VERSION} QUIET) # For Calendar tool.
-
- if ("${KF5CalendarCore_VERSION}" VERSION_GREATER 5.6.40)
- set(HAVE_KCALENDAR_QDATETIME TRUE)
- endif()
-
--if(ENABLE_AKONADICONTACTSUPPORT AND (NOT KF5AkonadiContact_FOUND OR NOT KF5Contacts_FOUND))
-- set(ENABLE_AKONADICONTACTSUPPORT OFF)
--endif()
--
--if(ENABLE_KFILEMETADATASUPPORT AND NOT KF5FileMetaData_FOUND)
-- set(ENABLE_KFILEMETADATASUPPORT OFF)
--endif()
--
- # Check if KIO have been compiled with KIOWidgets. digiKam only needs this one.
- if(KF5KIO_FOUND)
- get_target_property(KIOWidgets_INCLUDE_DIRS KF5::KIOWidgets
-@@ -296,7 +274,7 @@ endif()
- find_package(X11)
-
- if(X11_FOUND)
-- find_package(Qt5 ${QT_MIN_VERSION} NO_MODULE COMPONENTS X11Extras)
-+ find_package(Qt5X11Extras ${QT_MIN_VERSION} NO_MODULE)
- set(HAVE_X11 TRUE)
- else()
- set(HAVE_X11 FALSE)
---
-2.37.3
-
diff --git a/media-gfx/digikam/files/digikam-7.9.0-akonadi-23.04.patch b/media-gfx/digikam/files/digikam-7.9.0-akonadi-23.04.patch
deleted file mode 100644
index d9b46a7966f0..000000000000
--- a/media-gfx/digikam/files/digikam-7.9.0-akonadi-23.04.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 5b4ba173f6a84a8be1131b1523dc42df95171ec7 Mon Sep 17 00:00:00 2001
-From: Antonio Rojas <arojas@archlinux.org>
-Date: Thu, 20 Apr 2023 17:49:44 +0200
-Subject: [PATCH] Fix build with akonadi 23.04
-
-In KDE PIM 23.04 the KF5:: targets have been renamed to KPim5::
-While the KF5:: targets are kept for backwards compatibility, they no longer recursively include other KF5:: targets.
-We need to search for Akonadi explicitly so that the KF5::AkonadiCore target is defined.
----
- core/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
-index 4cb33d2f9e6..610033425cd 100644
---- a/core/CMakeLists.txt
-+++ b/core/CMakeLists.txt
-@@ -124,6 +124,7 @@ if(ENABLE_AKONADICONTACTSUPPORT)
-
- find_package(KF5 ${AKONADI_MIN_VERSION} QUIET REQUIRED
- OPTIONAL_COMPONENTS
-+ Akonadi
- AkonadiContact # For KDE Mail Contacts support.
- Contacts # API for contacts/address book data.
- )
---
-GitLab
-