summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/dispcalgui')
-rw-r--r--media-gfx/dispcalgui/Manifest4
-rw-r--r--media-gfx/dispcalgui/dispcalgui-1.2.7.0.ebuild78
-rw-r--r--media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild74
-rw-r--r--media-gfx/dispcalgui/dispcalgui-2.5.0.0.ebuild72
-rw-r--r--media-gfx/dispcalgui/dispcalgui-2.6.0.0.ebuild72
-rw-r--r--media-gfx/dispcalgui/files/dispcalgui-1.2.7.0-wxversion-select.patch11
-rw-r--r--media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch13
-rw-r--r--media-gfx/dispcalgui/metadata.xml20
8 files changed, 344 insertions, 0 deletions
diff --git a/media-gfx/dispcalgui/Manifest b/media-gfx/dispcalgui/Manifest
new file mode 100644
index 000000000000..7edb7563f484
--- /dev/null
+++ b/media-gfx/dispcalgui/Manifest
@@ -0,0 +1,4 @@
+DIST dispcalGUI-1.2.7.0.tar.gz 3302318 SHA256 8032b71ced4d7f718f8aa50a5dfc92595150334b572d6828c797426d8d63ba0b SHA512 7ae2c14c0fa50cb28284a24269c2d73bf5197326581cceb7436f1263f8097eb57c7cafbfaa811f1b387e4b7235fe8eda0a8f48ef939ec7710ca5555090ca53c3 WHIRLPOOL 106da953f564b2c4f6cdfefffc7952248b17793cd42e267c41f6bb3e56864b36d87f584df7b47f06ec131693c5de10e4f8630d77b12bdb82b318e61b4dec62d6
+DIST dispcalGUI-2.0.0.0.tar.gz 5914050 SHA256 fad516999bd663cf870fad2869fc63a23f93820dffff9dbd1029369417a6b650 SHA512 14e1a5d921ed4aaa07bd96d2c4256ce080bc6201d7a5b2a6fa69ae9ac25b8d34c9b0f3b3dac3d2e9a7d4c5faa97682e10a4b15205098a454623ecdb4e09eb8a5 WHIRLPOOL 1c88bb5da2dcddc1848249ba76057e1e33480e8fc344af6c3348d933c9752cc09f91a03a61f18f71cae27473956ae0e518b85864b5a2eb6ce9caf074d59f167c
+DIST dispcalGUI-2.5.0.0.tar.gz 6392054 SHA256 036a01a11551d990a6b84e241d131ca0b07d810d552b28332907aa6fb3cd4777 SHA512 d5cb2263739f9c46676222d20e570c161897af58bb359ed569a7690b6fc1ed83ce7e9862e7d69b1afb599b8035ca4f4abfccef83b877d98a34956535d2dd729b WHIRLPOOL 725de21d2d320ec74b6a7840cf5f251885b62946e20cfc7bed480f663c77116c9bac61b2df7e7ddfe7a0e7557269d864f0b88569e52463499eb310279fe66b7d
+DIST dispcalGUI-2.6.0.0.tar.gz 6722168 SHA256 3087facf1fd7941b04df327903eb9a49511987a9b7afaada9ee8ca4600d0109f SHA512 0f7b1952588ee8e5c49f3ce3be41e53c0dd746b6fd660107e78ec16b392ebda9f8bc45550a119371b2197fd370f0e28e05aee47c71e26cfb8f648a6d66277454 WHIRLPOOL 84f050ed73200054b7dad53730a86490e44e751ab96ef4ef3faea279ac692ef76685c8992135085c43c3e258e2fc44c5a276217443adc67560eb23b376d535d7
diff --git a/media-gfx/dispcalgui/dispcalgui-1.2.7.0.ebuild b/media-gfx/dispcalgui/dispcalgui-1.2.7.0.ebuild
new file mode 100644
index 000000000000..7754a5d178e4
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-1.2.7.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+
+inherit distutils fdo-mime eutils
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wxversion-select.patch
+
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}
diff --git a/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild b/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild
new file mode 100644
index 000000000000..4cebac91f191
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-wxversion-select.patch"
+
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/dispcalgui/dispcalgui-2.5.0.0.ebuild b/media-gfx/dispcalgui/dispcalgui-2.5.0.0.ebuild
new file mode 100644
index 000000000000..9f015e0c9764
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-2.5.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/dispcalgui/dispcalgui-2.6.0.0.ebuild b/media-gfx/dispcalgui/dispcalgui-2.6.0.0.ebuild
new file mode 100644
index 000000000000..44a916028b8b
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-2.6.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/dispcalgui/files/dispcalgui-1.2.7.0-wxversion-select.patch b/media-gfx/dispcalgui/files/dispcalgui-1.2.7.0-wxversion-select.patch
new file mode 100644
index 000000000000..8343b2be07c5
--- /dev/null
+++ b/media-gfx/dispcalgui/files/dispcalgui-1.2.7.0-wxversion-select.patch
@@ -0,0 +1,11 @@
+--- dispcalGUI/dispcalGUI.py.old 2013-04-19 01:04:23.663520256 +0300
++++ dispcalGUI/dispcalGUI.py 2013-04-19 01:06:49.561884072 +0300
+@@ -40,6 +40,9 @@
+
+ # Standard modules
+
++import wxversion
++wxversion.select("2.8")
++
+ import ConfigParser
+ ConfigParser.DEFAULTSECT = "Default"
diff --git a/media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch b/media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch
new file mode 100644
index 000000000000..dd3815df68cb
--- /dev/null
+++ b/media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch
@@ -0,0 +1,13 @@
+--- dispcalGUI/main.py.orig 2014-03-04 20:44:41.266561455 +0200
++++ dispcalGUI/main.py 2014-03-04 20:44:24.194511770 +0200
+@@ -19,6 +19,10 @@ if pyver < py_minversion or pyver > py_m
+ ".".join(str(n) for n in py_maxversion),
+ sys.version.split()[0]))
+
++# Gentoo compatibility module
++import wxversion
++wxversion.select("2.8")
++
+ from config import (autostart_home, datahome, enc, exe, exe_ext, exedir,
+ exename, fs_enc, isapp, isexe, pydir, pyname, pypath,
+ runtype)
diff --git a/media-gfx/dispcalgui/metadata.xml b/media-gfx/dispcalgui/metadata.xml
new file mode 100644
index 000000000000..3a8ed7223da0
--- /dev/null
+++ b/media-gfx/dispcalgui/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>opensource@andmarios.com</email>
+ <name>Marios Andreopoulos</name>
+ <description>Maintainer.</description>
+ </maintainer>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ <description>Proxy maintainer.</description>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">dispcalgui</remote-id>
+ </upstream>
+</pkgmetadata>