summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fontforge')
-rw-r--r--media-gfx/fontforge/Manifest1
-rw-r--r--media-gfx/fontforge/files/20200314-MacServiceReadFDs.patch38
-rw-r--r--media-gfx/fontforge/files/20200314-big-endian.patch298
-rw-r--r--media-gfx/fontforge/files/20200314-stylemap.patch30
-rw-r--r--media-gfx/fontforge/files/20200314-tilepath.patch31
-rw-r--r--media-gfx/fontforge/files/fontforge-20200314-freetype-2.10.3.patch60
-rw-r--r--media-gfx/fontforge/fontforge-20200314.ebuild117
7 files changed, 0 insertions, 575 deletions
diff --git a/media-gfx/fontforge/Manifest b/media-gfx/fontforge/Manifest
index 74c0099dc368..11eaed591734 100644
--- a/media-gfx/fontforge/Manifest
+++ b/media-gfx/fontforge/Manifest
@@ -1,2 +1 @@
-DIST fontforge-20200314.tar.xz 13850076 BLAKE2B 5e6ae3b7940a5b3b08811abdfc9d151f231e6d457b219eb0c666e1b831db815b696f345eda0d4d423b7e340f56fca67205734ae19903b3815381080d34b5e95c SHA512 09f5dc93f87ca63668d72d108690604489d6b3cec7eedff1c07ad6d1ce5eae442ab60e79e71ae8b99e9808f3551011788025a86ffc3a9738518d99761d849975
DIST fontforge-20201107.tar.xz 14163424 BLAKE2B 8ce9148eef6e5b7206ab5c70310ff36fac67c392117e3c0b28060803a54306bf21c179b62b98734e11253739eac29e2ea8bcf3014c09432bb3a0b2b0f3ec631a SHA512 cf9666395405ab02943f0160959f04251bd2a80e279a8f60431089ad19a4c5a232efd42097050ed9f6c1fb39d01488176262949fd81f5f0960fe853b497437dc
diff --git a/media-gfx/fontforge/files/20200314-MacServiceReadFDs.patch b/media-gfx/fontforge/files/20200314-MacServiceReadFDs.patch
deleted file mode 100644
index d6beff7984c9..000000000000
--- a/media-gfx/fontforge/files/20200314-MacServiceReadFDs.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 5a3d2ce60aeefd706c36a8325721b0c8c818c742 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 1 May 2020 05:06:07 -0400
-Subject: [PATCH] Stub-out MacServiceReadFDs() on non-Mac platforms (#4246)
-
-This should fix a build failure on Linux with musl libc due to the
-missing sys/select.h include.
-
-MacServiceReadFDs seems to only be called in startui.c, also behind the
-__Mac macro.
-
-Bug: https://bugs.gentoo.org/706792
----
- gdraw/gdraw.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/gdraw/gdraw.c b/gdraw/gdraw.c
-index 1fb3354b1d..6bac57b92a 100644
---- a/gdraw/gdraw.c
-+++ b/gdraw/gdraw.c
-@@ -32,7 +32,7 @@
- #include "gkeysym.h"
- #include "ustring.h"
-
--#if __Mac || __FreeBSD__ || __NetBSD__ || __OpenBSD__ || __DragonFly__
-+#if __Mac
- # include <sys/select.h>
- #endif
-
-@@ -1076,7 +1076,7 @@ GDrawRemoveReadFD( GDisplay *gdisp,
-
- void MacServiceReadFDs()
- {
--#if (!defined(__MINGW32__))&&(!defined(__CYGWIN__))
-+#if __Mac
- int ret = 0;
-
- GDisplay *gdisp = GDrawGetDisplayOfWindow(0);
diff --git a/media-gfx/fontforge/files/20200314-big-endian.patch b/media-gfx/fontforge/files/20200314-big-endian.patch
deleted file mode 100644
index f9581ad35f42..000000000000
--- a/media-gfx/fontforge/files/20200314-big-endian.patch
+++ /dev/null
@@ -1,298 +0,0 @@
-From 65619185a42bd52bb4a4894c1714d78d96ed4175 Mon Sep 17 00:00:00 2001
-From: Jeremy Tan <jtanx@outlook.com>
-Date: Sun, 26 Apr 2020 18:57:58 +1000
-Subject: [PATCH 1/2] tottfgpos.c: fix incorrect sizing of the scripts array
-
-latn contains 58 entries (29 pairs), meaning the size was too small
-to fit the 0 marker at the end of the array
----
- fontforge/tottfgpos.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/fontforge/tottfgpos.c b/fontforge/tottfgpos.c
-index 5de5164ed1..e12a0b8a79 100644
---- a/fontforge/tottfgpos.c
-+++ b/fontforge/tottfgpos.c
-@@ -60,7 +60,7 @@ int use_second_indic_scripts = false;
- /* scripts (for opentype) that I understand */
- /* see also list in lookups.c mapping script tags to friendly names */
-
--static uint32 scripts[][59] = {
-+static uint32 scripts[][61] = {
- /* Adlam */ { CHR('a','d','l','m'), 0x1e900, 0x1e95f },
- /* Ahom */ { CHR('a','h','o','m'), 0x11700, 0x1173f },
- /* Anatolian */ { CHR('h','l','u','w'), 0x14400, 0x1467f },
-
-From fde85b13382595cb3ab889e38570b4944edad808 Mon Sep 17 00:00:00 2001
-From: Jeremy Tan <jtanx@outlook.com>
-Date: Sun, 26 Apr 2020 19:00:04 +1000
-Subject: [PATCH 2/2] python.c: fix type specifier on long input/return values
-
-int is guaranteed to be at least 16 bits, while long is at least
-32 bits. So for uint32/int32 values, parse longs with the "l"/"k"
-specifier and cast return values to long.
-
-The cast is necessary as on amd64 a long is 64 bits
----
- fontforge/python.c | 68 +++++++++++++++++++++++-----------------------
- 1 file changed, 34 insertions(+), 34 deletions(-)
-
-diff --git a/fontforge/python.c b/fontforge/python.c
-index 5344b0f60f..6c9675fa4e 100644
---- a/fontforge/python.c
-+++ b/fontforge/python.c
-@@ -760,7 +760,7 @@ static PyObject *PyFF_UnicodeAnnotationFromLib(PyObject *UNUSED(self), PyObject
- char *temp;
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
- if ( (temp=unicode_annot(val))==NULL ) {
-@@ -777,7 +777,7 @@ static PyObject *PyFF_UnicodeNameFromLib(PyObject *UNUSED(self), PyObject *args)
- char *temp;
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
- if ( (temp=unicode_name(val))==NULL ) {
-@@ -798,10 +798,10 @@ static PyObject *PyFF_UnicodeBlockStartFromLib(PyObject *UNUSED(self), PyObject
- /* Use this function with UnicodeBlockNameFromLib(n) & UnicodeBlockEndFromLib(n). */
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
-- return( Py_BuildValue("i", unicode_block_start(val)) );
-+ return( Py_BuildValue("l", (long)unicode_block_start(val)) );
- }
-
- static PyObject *PyFF_UnicodeBlockEndFromLib(PyObject *UNUSED(self), PyObject *args) {
-@@ -809,10 +809,10 @@ static PyObject *PyFF_UnicodeBlockEndFromLib(PyObject *UNUSED(self), PyObject *a
- /* Use this function with UnicodeBlockStartFromLib(n), UnicodeBlockNameFromLib(n) */
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
-- return( Py_BuildValue("i", unicode_block_end(val)) );
-+ return( Py_BuildValue("l", (long)unicode_block_end(val)) );
- }
-
- static PyObject *PyFF_UnicodeBlockNameFromLib(PyObject *UNUSED(self), PyObject *args) {
-@@ -822,7 +822,7 @@ static PyObject *PyFF_UnicodeBlockNameFromLib(PyObject *UNUSED(self), PyObject *
- char *temp;
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
- if ( (temp=unicode_block_name(val))==NULL ) {
-@@ -853,24 +853,24 @@ static PyObject *PyFF_UnicodeNames2GetCntFromLib(PyObject *UNUSED(self), PyObjec
- static PyObject *PyFF_UnicodeNames2GetNxtFromLib(PyObject *UNUSED(self), PyObject *args) {
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-- return( Py_BuildValue("i", unicode_names2getUtabLoc(val)) );
-+ return( Py_BuildValue("l", (long)unicode_names2getUtabLoc(val)) );
- }
-
- static PyObject *PyFF_UnicodeNames2NxtUniFromLib(PyObject *UNUSED(self), PyObject *args) {
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-- return( Py_BuildValue("i", unicode_names2valFrmTab(val)) );
-+ return( Py_BuildValue("l", (long)unicode_names2valFrmTab(val)) );
- }
-
- static PyObject *PyFF_UnicodeNames2FrmTabFromLib(PyObject *UNUSED(self), PyObject *args) {
- long val;
- char *temp;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
- if ( (temp=unicode_name2FrmTab(val))==NULL ) {
- return Py_BuildValue("s", "");
-@@ -883,7 +883,7 @@ static PyObject *PyFF_UnicodeNames2FromLib(PyObject *UNUSED(self), PyObject *arg
- long val;
- char *temp;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
- if ( (temp=unicode_name2(val))==NULL ) {
- return Py_BuildValue("s", "");
-@@ -899,7 +899,7 @@ static PyObject *PyFF_UnicodeNames2FromLib(PyObject *UNUSED(self), PyObject *arg
- static PyObject *PyFF_isligature(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", is_LIGATURE(codepoint)==0?1:0) );
-@@ -908,7 +908,7 @@ static PyObject *PyFF_isligature(PyObject *UNUSED(self), PyObject *args) {
- static PyObject *PyFF_isvulgarfraction(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", is_VULGAR_FRACTION(codepoint)==0?1:0) );
-@@ -917,7 +917,7 @@ static PyObject *PyFF_isvulgarfraction(PyObject *UNUSED(self), PyObject *args) {
- static PyObject *PyFF_isotherfraction(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", is_OTHER_FRACTION(codepoint)==0?1:0) );
-@@ -926,7 +926,7 @@ static PyObject *PyFF_isotherfraction(PyObject *UNUSED(self), PyObject *args) {
- static PyObject *PyFF_isfraction(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", (is_VULGAR_FRACTION(codepoint)==0 || \
-@@ -957,28 +957,28 @@ static PyObject *PyFF_FracChartGetCnt(PyObject *UNUSED(self), PyObject *UNUSED(a
- static PyObject *PyFF_LigChartGetNxt(PyObject *UNUSED(self), PyObject *args) {
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
-- return( Py_BuildValue("i", Ligature_get_U(val)) );
-+ return( Py_BuildValue("l", (long)Ligature_get_U(val)) );
- }
-
- static PyObject *PyFF_VulChartGetNxt(PyObject *UNUSED(self), PyObject *args) {
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
-- return( Py_BuildValue("i", VulgFrac_get_U(val)) );
-+ return( Py_BuildValue("l", (long)VulgFrac_get_U(val)) );
- }
-
- static PyObject *PyFF_OFracChartGetNxt(PyObject *UNUSED(self), PyObject *args) {
- long val;
-
-- if ( !PyArg_ParseTuple(args,"|i",&val) )
-+ if ( !PyArg_ParseTuple(args,"|l",&val) )
- return( NULL );
-
-- return( Py_BuildValue("i", Fraction_get_U(val)) );
-+ return( Py_BuildValue("l", (long)Fraction_get_U(val)) );
- }
-
- /* If you have a unicode ligature, or fraction, these routines return loc n. */
-@@ -987,7 +987,7 @@ static PyObject *PyFF_OFracChartGetNxt(PyObject *UNUSED(self), PyObject *args) {
- static PyObject *PyFF_LigChartGetLoc(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", Ligature_find_N(codepoint)) );
-@@ -996,7 +996,7 @@ static PyObject *PyFF_LigChartGetLoc(PyObject *UNUSED(self), PyObject *args) {
- static PyObject *PyFF_VulChartGetLoc(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", VulgFrac_find_N(codepoint)) );
-@@ -1005,7 +1005,7 @@ static PyObject *PyFF_VulChartGetLoc(PyObject *UNUSED(self), PyObject *args) {
- static PyObject *PyFF_OFracChartGetLoc(PyObject *UNUSED(self), PyObject *args) {
- long codepoint;
-
-- if ( !PyArg_ParseTuple(args,"|i",&codepoint) )
-+ if ( !PyArg_ParseTuple(args,"|l",&codepoint) )
- return( NULL );
-
- return( Py_BuildValue("i", Fraction_find_N(codepoint)) );
-@@ -1066,7 +1066,7 @@ static PyObject *PyFF_LigChartGetAltVal(PyObject *UNUSED(self), PyObject *args)
-
- if ( !PyArg_ParseTuple(args,"ll",&nthCode, &altN) )
- return( NULL );
-- return( Py_BuildValue("i", Ligature_alt_getV(nthCode,altN)) );
-+ return( Py_BuildValue("l", (long)Ligature_alt_getV(nthCode,altN)) );
- }
-
- static PyObject *PyFF_LigChartUGetAltVal(PyObject *UNUSED(self), PyObject *args) {
-@@ -1074,7 +1074,7 @@ static PyObject *PyFF_LigChartUGetAltVal(PyObject *UNUSED(self), PyObject *args)
-
- if ( !PyArg_ParseTuple(args,"ll",&nthCode, &altN) )
- return( NULL );
-- return( Py_BuildValue("i", LigatureU_alt_getV(nthCode,altN)) );
-+ return( Py_BuildValue("l", (long)LigatureU_alt_getV(nthCode,altN)) );
- }
-
- static PyObject *PyFF_VulChartGetAltVal(PyObject *UNUSED(self), PyObject *args) {
-@@ -1082,7 +1082,7 @@ static PyObject *PyFF_VulChartGetAltVal(PyObject *UNUSED(self), PyObject *args)
-
- if ( !PyArg_ParseTuple(args,"ll",&nthCode, &altN) )
- return( NULL );
-- return( Py_BuildValue("i", VulgFrac_alt_getV(nthCode,altN)) );
-+ return( Py_BuildValue("l", (long)VulgFrac_alt_getV(nthCode,altN)) );
- }
-
- static PyObject *PyFF_VulChartUGetAltVal(PyObject *UNUSED(self), PyObject *args) {
-@@ -1090,7 +1090,7 @@ static PyObject *PyFF_VulChartUGetAltVal(PyObject *UNUSED(self), PyObject *args)
-
- if ( !PyArg_ParseTuple(args,"ll",&nthCode, &altN) )
- return( NULL );
-- return( Py_BuildValue("i", VulgFracU_alt_getV(nthCode,altN)) );
-+ return( Py_BuildValue("l", (long)VulgFracU_alt_getV(nthCode,altN)) );
- }
-
- static PyObject *PyFF_OFracChartGetAltVal(PyObject *UNUSED(self), PyObject *args) {
-@@ -1098,7 +1098,7 @@ static PyObject *PyFF_OFracChartGetAltVal(PyObject *UNUSED(self), PyObject *args
-
- if ( !PyArg_ParseTuple(args,"ll",&nthCode, &altN) )
- return( NULL );
-- return( Py_BuildValue("i", Fraction_alt_getV(nthCode,altN)) );
-+ return( Py_BuildValue("l", (long)Fraction_alt_getV(nthCode,altN)) );
- }
-
- static PyObject *PyFF_OFracChartUGetAltVal(PyObject *UNUSED(self), PyObject *args) {
-@@ -1106,7 +1106,7 @@ static PyObject *PyFF_OFracChartUGetAltVal(PyObject *UNUSED(self), PyObject *arg
-
- if ( !PyArg_ParseTuple(args,"ll",&nthCode, &altN) )
- return( NULL );
-- return( Py_BuildValue("i", FractionU_alt_getV(nthCode,altN)) );
-+ return( Py_BuildValue("l", (long)FractionU_alt_getV(nthCode,altN)) );
- }
-
- static PyObject *PyFF_Version(PyObject *UNUSED(self), PyObject *UNUSED(args)) {
-@@ -1542,8 +1542,8 @@ return( ret );
- }
-
- static PyObject *PyFF_scriptFromUnicode(PyObject *UNUSED(self), PyObject *args) {
-- long u;
-- if ( !PyArg_ParseTuple(args,"i",&u) )
-+ unsigned long u;
-+ if ( !PyArg_ParseTuple(args,"k",&u) )
- return( NULL );
-
- uint32 script = ScriptFromUnicode(u, NULL);
diff --git a/media-gfx/fontforge/files/20200314-stylemap.patch b/media-gfx/fontforge/files/20200314-stylemap.patch
deleted file mode 100644
index d3311cab02d2..000000000000
--- a/media-gfx/fontforge/files/20200314-stylemap.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3b83adc89771000eb95fcd87bb675f771ba85aaf Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sun, 29 Mar 2020 16:36:14 -0400
-Subject: [PATCH] Avoid integer size conflict when setting stylemap
-
-stylemap is a 16-bit integer, but hexmap writes 32-bits.
-
-Bug: https://bugs.gentoo.org/642756
----
- fontforge/sfd.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/fontforge/sfd.c b/fontforge/sfd.c
-index 9517d8cb1..b638fe447 100644
---- a/fontforge/sfd.c
-+++ b/fontforge/sfd.c
-@@ -8104,7 +8104,9 @@ bool SFD_GetFontMetaData( FILE *sfd,
- }
- else if ( strmatch(tok,"StyleMap:")==0 )
- {
-- gethex(sfd,(uint32 *)&sf->pfminfo.stylemap);
-+ uint32 u;
-+ gethex(sfd,&u);
-+ sf->pfminfo.stylemap = u;
- }
- /* Legacy attribute for StyleMap. Deprecated. */
- else if ( strmatch(tok,"OS2StyleName:")==0 )
---
-2.26.0.rc2
-
diff --git a/media-gfx/fontforge/files/20200314-tilepath.patch b/media-gfx/fontforge/files/20200314-tilepath.patch
deleted file mode 100644
index 1e0d077532a4..000000000000
--- a/media-gfx/fontforge/files/20200314-tilepath.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 43e6087ec9bdbb23b8bb61c07efe6490fab23d73 Mon Sep 17 00:00:00 2001
-From: skef <6175836+skef@users.noreply.github.com>
-Date: Thu, 19 Mar 2020 17:16:20 -0700
-Subject: [PATCH] Tilepath fix (#4231)
-
----
- fontforgeexe/tilepath.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/fontforgeexe/tilepath.c b/fontforgeexe/tilepath.c
-index b329b54098..2575058eb4 100644
---- a/fontforgeexe/tilepath.c
-+++ b/fontforgeexe/tilepath.c
-@@ -571,7 +571,7 @@ static void AdjustPoint(TD *td,Spline *spline,bigreal t, FitPoint *to) {
- } else {
- bigreal s=(dy1*dx2/dy2-dx1);
- if ( s>-.00001 && s<.00001 ) { /* essentially parallel */
-- to->p.x = x1; to->y = y1;
-+ to->p.x = x1; to->p.y = y1;
- } else {
- bigreal t1 = (x1-x2- dx2/dy2*(y1-y2))/s;
- to->p.x = x1 + dx1*t1;
-@@ -610,7 +610,7 @@ static SplinePoint *TDMakePoint(TD *td,Spline *old,real t) {
-
- AdjustPoint(td,old,t,&fp);
- new = chunkalloc(sizeof(SplinePoint));
-- new->me.x = tp.p.x; new->me.y = tp.p.y;
-+ new->me.x = fp.p.x; new->me.y = fp.p.y;
- new->nextcp = new->me;
- new->prevcp = new->me;
- new->nonextcp = new->noprevcp = true;
diff --git a/media-gfx/fontforge/files/fontforge-20200314-freetype-2.10.3.patch b/media-gfx/fontforge/files/fontforge-20200314-freetype-2.10.3.patch
deleted file mode 100644
index 0a07423ab626..000000000000
--- a/media-gfx/fontforge/files/fontforge-20200314-freetype-2.10.3.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-https://bugs.gentoo.org/753788
-https://github.com/fontforge/fontforge/commit/7837530190a3b666109ba4eb9b3b76f09799057c
-----
-From 7837530190a3b666109ba4eb9b3b76f09799057c Mon Sep 17 00:00:00 2001
-From: Jeremy Tan <jtanx@outlook.com>
-Date: Tue, 3 Nov 2020 21:27:26 +1100
-Subject: [PATCH] Fix FreeType debugger compilation with FreeType >= 2.10.3
-
-Fixes #4477
----
- fontforge/fffreetype.h | 4 +++-
- fontforgeexe/cvdebug.c | 4 +++-
- fontforgeexe/cvdgloss.c | 4 +++-
- 3 files changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/fontforge/fffreetype.h b/fontforge/fffreetype.h
-index 7757b7bf3b..11070fc916 100644
---- a/fontforge/fffreetype.h
-+++ b/fontforge/fffreetype.h
-@@ -39,7 +39,9 @@
- #endif
-
- #if defined(FREETYPE_HAS_DEBUGGER)
--# include <internal/internal.h>
-+#if FREETYPE_MAJOR == 2 && (FREETYPE_MINOR < 10 || (FREETYPE_MINOR == 10 && FREETYPE_PATCH < 3))
-+# include <internal/internal.h>
-+# endif
- # include <ttdriver.h>
- # include <ttinterp.h>
- # include <ttobjs.h>
-diff --git a/fontforgeexe/cvdebug.c b/fontforgeexe/cvdebug.c
-index 9fb7db6112..a891902a06 100644
---- a/fontforgeexe/cvdebug.c
-+++ b/fontforgeexe/cvdebug.c
-@@ -59,7 +59,9 @@ void CVDebugPointPopup(CharView *cv) {
- #include <ft2build.h>
- #include FT_FREETYPE_H
-
--#include <internal/internal.h>
-+#if FREETYPE_MAJOR == 2 && (FREETYPE_MINOR < 10 || (FREETYPE_MINOR == 10 && FREETYPE_PATCH < 3))
-+# include <internal/internal.h>
-+#endif
- #include <ttinterp.h>
-
- # define PPEMX(exc) ((exc)->size->root.metrics.x_ppem)
-diff --git a/fontforgeexe/cvdgloss.c b/fontforgeexe/cvdgloss.c
-index 33cc5c71e1..c1ad97790b 100644
---- a/fontforgeexe/cvdgloss.c
-+++ b/fontforgeexe/cvdgloss.c
-@@ -42,7 +42,9 @@ extern GBox _ggadget_Default_Box;
- #include <ft2build.h>
- #include FT_FREETYPE_H
-
--#include <internal/internal.h>
-+#if FREETYPE_MAJOR == 2 && (FREETYPE_MINOR < 10 || (FREETYPE_MINOR == 10 && FREETYPE_PATCH < 3))
-+# include <internal/internal.h>
-+#endif
- #include <ttinterp.h>
-
- #define PPEMX(exc) ((exc)->size->root.metrics.x_ppem)
diff --git a/media-gfx/fontforge/fontforge-20200314.ebuild b/media-gfx/fontforge/fontforge-20200314.ebuild
deleted file mode 100644
index 8136d074c603..000000000000
--- a/media-gfx/fontforge/fontforge-20200314.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 2004-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit python-single-r1 xdg cmake
-
-DESCRIPTION="postscript font editor and converter"
-HOMEPAGE="https://fontforge.org/"
-SRC_URI="https://github.com/fontforge/fontforge/releases/download/${PV}/fontforge-${PV}.tar.xz"
-
-LICENSE="BSD GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc truetype-debugger gif gtk jpeg png +python readline test tiff svg unicode woff2 X"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/libltdl:0
- dev-libs/libxml2:2=
- >=media-libs/freetype-2.3.7:2=
- gif? ( media-libs/giflib:0= )
- jpeg? ( virtual/jpeg:0 )
- png? ( media-libs/libpng:0= )
- tiff? ( media-libs/tiff:0= )
- truetype-debugger? ( >=media-libs/freetype-2.3.8:2[fontforge,-bindist(-)] )
- gtk? ( >=x11-libs/gtk+-3.10:3 )
- !gtk? (
- X? (
- >=x11-libs/cairo-1.6:0=
- >=x11-libs/pango-1.10:0=[X]
- x11-libs/libX11:0=
- x11-libs/libXi:0=
- )
- )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:0= )
- unicode? ( media-libs/libuninameslist:0= )
- woff2? ( media-libs/woff2:0= )
-"
-DEPEND="${RDEPEND}
- !gtk? ( X? ( x11-base/xorg-proto ) )
-"
-BDEPEND="
- sys-devel/gettext
- doc? ( >=dev-python/sphinx-2 )
- python? ( ${PYTHON_DEPS} )
- test? ( ${RDEPEND} )
-"
-
-PATCHES=(
- "${FILESDIR}"/20200314-stylemap.patch
- "${FILESDIR}"/20200314-tilepath.patch
- "${FILESDIR}"/20200314-big-endian.patch
- "${FILESDIR}"/fontforge-doc-no-warn-error.patch
- "${FILESDIR}"/20200314-MacServiceReadFDs.patch
- "${FILESDIR}"/${P}-freetype-2.10.3.patch
-)
-
-pkg_setup() {
- :
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DOCS=$(usex doc ON OFF)
- -DENABLE_LIBGIF=$(usex gif ON OFF)
- -DENABLE_LIBJPEG=$(usex jpeg ON OFF)
- -DENABLE_LIBPNG=$(usex png ON OFF)
- -DENABLE_LIBREADLINE=$(usex readline ON OFF)
- -DENABLE_LIBSPIRO=OFF # No package in Gentoo
- -DENABLE_LIBTIFF=$(usex tiff ON OFF)
- -DENABLE_LIBUNINAMESLIST=$(usex unicode ON OFF)
- -DENABLE_MAINTAINER_TOOLS=OFF
- -DENABLE_PYTHON_EXTENSION=$(usex python ON OFF)
- -DENABLE_PYTHON_SCRIPTING=$(usex python ON OFF)
- -DENABLE_TILE_PATH=ON
- -DENABLE_WOFF2=$(usex woff2 ON OFF)
- )
-
- if use gtk || use X; then
- mycmakeargs+=(
- -DENABLE_GUI=ON
- # Prefer GTK over X11 if both USE flage are enabled
- -DENABLE_X11=$(usex gtk OFF ON)
- )
- else
- mycmakeargs+=( -DENABLE_GUI=OFF )
- fi
-
- if use python; then
- python_setup
- mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
- fi
-
- if use truetype-debugger ; then
- local ft2="${ESYSROOT}/usr/include/freetype2"
- local ft2i="${ft2}/internal4fontforge"
- mycmakeargs+=(
- -DENABLE_FREETYPE_DEBUGGER="${ft2}"
- -DFreeTypeSource_INCLUDE_DIRS="${ft2};${ft2i}/include;${ft2i}/include/freetype;${ft2i}/src/truetype"
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- docompress -x /usr/share/doc/${PF}/html
- einstalldocs
- find "${ED}" -name '*.la' -type f -delete || die
-}