summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fotocx')
-rw-r--r--media-gfx/fotocx/Manifest2
-rw-r--r--media-gfx/fotocx/files/fotoxx-22.18-documentation.patch23
-rw-r--r--media-gfx/fotocx/files/fotoxx-22.82-documentation.patch27
-rw-r--r--media-gfx/fotocx/fotocx-23.70.ebuild81
-rw-r--r--media-gfx/fotocx/fotocx-23.82.ebuild81
-rw-r--r--media-gfx/fotocx/metadata.xml18
6 files changed, 232 insertions, 0 deletions
diff --git a/media-gfx/fotocx/Manifest b/media-gfx/fotocx/Manifest
new file mode 100644
index 000000000000..f071f96ddca9
--- /dev/null
+++ b/media-gfx/fotocx/Manifest
@@ -0,0 +1,2 @@
+DIST fotoxx-23.70-source.tar.gz 16130595 BLAKE2B d5cd0453c7cc568ddc5a8d66d5f79f4a907a52aa0d635cb32701a4293a210d703e05056a1140287d20434c636f5acffc869af135cf8a3f3762ca55e10e102a05 SHA512 3616f3e90e973c872b25607951ebd41f851df45b715cb3c2df982c1f74387d9cbf0ee5fc14f3de4ecb4e3251ba25affe6cd3b5e118bce31ff01c14637d588c5d
+DIST fotoxx-23.82-source.tar.gz 16257916 BLAKE2B b985d999003ebf53dea5f4f21bca7ecd451d89a14c98aa5269f892f183e28f01a81a33bf2a92e6cef98a466069b20622e829eee897d5d818a6f27c493de48734 SHA512 1c6ded03207eaf2e890fa642ff6d9e0bfaae551e9ec1169b30f3ef8a4763cda01dddc7e0c62e7da29a397ad22c4702c0613d383804563b065ce334918381bd2d
diff --git a/media-gfx/fotocx/files/fotoxx-22.18-documentation.patch b/media-gfx/fotocx/files/fotoxx-22.18-documentation.patch
new file mode 100644
index 000000000000..23d9509458d9
--- /dev/null
+++ b/media-gfx/fotocx/files/fotoxx-22.18-documentation.patch
@@ -0,0 +1,23 @@
+--- a/Makefile
++++ b/Makefile
+@@ -122,8 +123,7 @@
+ cp -f -R data/* $(DESTDIR)$(DATADIR)
+ cp -f -R images/* $(DESTDIR)$(IMAGEDIR)
+ # man page
+- gzip -fk -9 man/fotoxx.man
+- mv -f man/fotoxx.man.gz $(DESTDIR)$(MANDIR)/fotoxx.1.gz
++ cp man/fotoxx.man $(DESTDIR)$(MANDIR)/fotoxx.1
+ # desktop file and icon
+ cp -f fotoxx.desktop $(DESTDIR)$(MENUDIR)
+ cp -f fotoxx.png $(DESTDIR)$(ICONDIR)
+--- a/zfuncs.cc
++++ b/zfuncs.cc
+@@ -6106,7 +6106,7 @@
+
+ strncatv(zdatadir,199,zprefix,"/share/",zappname,"/data",null); // /prefix/share/appname/data
+ strncatv(zimagedir,199,zprefix,"/share/",zappname,"/images",null); // /prefix/share/appname/images
+- strncatv(zdocdir,199,zprefix,"/share/doc/",zappname,null); // /prefix/share/doc/appname
++ strncatv(zdocdir,199,zprefix,"/share/doc/",zappvers,null); // /prefix/share/doc/appname
+
+ ch_time = zstrdup(build_date_time,"zinitapp");
+ if (ch_time[4] == ' ') ch_time[4] = '0'; // replace month day ' d' with '0d'
diff --git a/media-gfx/fotocx/files/fotoxx-22.82-documentation.patch b/media-gfx/fotocx/files/fotoxx-22.82-documentation.patch
new file mode 100644
index 000000000000..80910d4331d9
--- /dev/null
+++ b/media-gfx/fotocx/files/fotoxx-22.82-documentation.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile b/Makefile
+index f80e166..8c1e794 100644
+--- a/Makefile
++++ b/Makefile
+@@ -128,8 +128,7 @@ install: fotoxx uninstall
+ cp -f -R images/* $(DESTDIR)$(IMAGEDIR)
+ cp -f metainfo/* $(DESTDIR)$(METAINFODIR)
+ # man page
+- gzip -fk -9 man/fotoxx.man
+- mv -f man/fotoxx.man.gz $(DESTDIR)$(MANDIR)/fotoxx.1.gz
++ cp man/fotoxx.man $(DESTDIR)$(MANDIR)/fotoxx.1
+ # desktop file and icon
+ cp -f fotoxx.desktop $(DESTDIR)$(MENUDIR)
+ cp -f fotoxx.png $(DESTDIR)$(ICONDIR)
+diff --git a/zfuncs.cc b/zfuncs.cc
+index 3ecf485..23f8d2d 100644
+--- a/zfuncs.cc
++++ b/zfuncs.cc
+@@ -6123,7 +6123,7 @@ int zinitapp(ch *appvers, int argc, ch *argv[])
+
+ strncatv(zdatadir,199,zprefix,"/share/",zappname,"/data",null); // /prefix/share/appname/data
+ strncatv(zimagedir,199,zprefix,"/share/",zappname,"/images",null); // /prefix/share/appname/images
+- strncatv(zdocdir,199,zprefix,"/share/doc/",zappname,null); // /prefix/share/doc/appname
++ strncatv(zdocdir,199,zprefix,"/share/doc/",zappvers,null); // /prefix/share/doc/appname-version
+
+ ch_time = zstrdup(build_date_time,"zinitapp");
+ if (ch_time[4] == ' ') ch_time[4] = '0'; // replace month day ' d' with '0d'
diff --git a/media-gfx/fotocx/fotocx-23.70.ebuild b/media-gfx/fotocx/fotocx-23.70.ebuild
new file mode 100644
index 000000000000..5ca640ae39ae
--- /dev/null
+++ b/media-gfx/fotocx/fotocx-23.70.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/fotoxx-${PV}-source.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/fotoxx"
+
+PATCHES=( "${FILESDIR}/fotoxx-22.18-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/fotoxx$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" fotoxx.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/media-gfx/fotocx/fotocx-23.82.ebuild b/media-gfx/fotocx/fotocx-23.82.ebuild
new file mode 100644
index 000000000000..cd89c8d333dc
--- /dev/null
+++ b/media-gfx/fotocx/fotocx-23.82.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/fotoxx-${PV}-source.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/fotoxx"
+
+PATCHES=( "${FILESDIR}/fotoxx-22.82-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/fotoxx$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" fotoxx.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/media-gfx/fotocx/metadata.xml b/media-gfx/fotocx/metadata.xml
new file mode 100644
index 000000000000..cea98fc29422
--- /dev/null
+++ b/media-gfx/fotocx/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <longdescription lang="en">
+ Navigate a large image collection using a thumbnail browser.
+ Import camera RAW files and edit with 16-bit color.
+ Save edited images as TIFF-8/16, PNG or JPEG with adjustable compression.
+ Edit the whole image or a selected area, with adjustable edge-blending.
+ Edit functions have live feedback using the full window.
+ Undo/redo up to 99 edits. Add tags, dates, and star-ratings to images
+ and search using these criteria and (wildcard) file names.
+ Fotoxx does not use filters, layers, and masks - the edit functions work directly on the image.
+ </longdescription>
+</pkgmetadata>