summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gifsicle/gifsicle-1.94.ebuild')
-rw-r--r--media-gfx/gifsicle/gifsicle-1.94.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/gifsicle/gifsicle-1.94.ebuild b/media-gfx/gifsicle/gifsicle-1.94.ebuild
new file mode 100644
index 000000000000..f5f90f0899a5
--- /dev/null
+++ b/media-gfx/gifsicle/gifsicle-1.94.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Create, manipulate, and optimize GIF images and animations"
+HOMEPAGE="https://www.lcdf.org/~eddietwo/gifsicle/ https://github.com/kohler/gifsicle"
+SRC_URI="https://www.lcdf.org/~eddietwo/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="X"
+
+PATCHES=( "${FILESDIR}/$P-CVE-2023-46009.patch" )
+
+RDEPEND="
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+DOCS=(
+ NEWS.md
+ README.md
+)
+
+src_configure() {
+ econf $(use_enable X gifview)
+}